can not delete a subnet because of serviceAssociationLinks/AppServiceLink

中垣 茂(ESM) 0 Reputation points
2023-10-10T01:07:19.3566667+00:00

Hi.

I built Azure infrastructure with terraform and tried to delete infrastructure with terraform. However one subnet couldn't be deleted because of serviceAssociationLinks/AppServiceLink. also I tried to delete manually a subnet but it didn't work at all.

I read the following article but it doesn't work for my case.

https://learn.microsoft.com/en-us/answers/questions/140197/unable-to-delete-vnet-due-to-serviceassociationlin

I know this's a duplicated question. But I can't create a support request and Microsoft QA needs a post here, I think.

Please give me a free one-time support ticket.

Thanks

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
2,197 questions
{count} votes

1 answer

Sort by: Most helpful
  1. GitaraniSharma-MSFT 48,011 Reputation points Microsoft Employee
    2023-10-26T11:57:14.6433333+00:00

    Hello @中垣 茂(ESM) ,

    I understand that you were unable to delete a subnet because of serviceAssociationLinks/AppServiceLink and you already tried the steps mentioned here but it didn't help.

    We offered you one-time free support as you requested, but you didn't have the permissions to create support requests in Azure portal, so you asked your service provider, and they created a support request for this issue.

    The support team removed the orphaned link from the backend, and you were able to delete the subnet now.

    Kindly let us know if you need further assistance on this issue.


    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments