Ao fazer uma chamada para o Azure Cognitive Search, para executar um indexer, ele executa um dia antes do dia atual. Por quê?

Joao Pedro Alves 60 Reputation points

Tenho um recurso do Azure Cognitive Search, e uma API que uso para automatizar algumas operações no Azure Cognitive Search, como por exemplo: resetar o Indexer e executar o Indexer. Mas estou tendo problema com ele, a dois dias. Quando a API realiza a chamada para executar o Indexer, o Indexer é executado um dia antes do dia que foi feita a chamanda. Por conta do erro o Azure Cognitive Search apresenta um erro de TimeOut.

User's image

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
741 questions
A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.
986 questions
{count} votes

Accepted answer
  1. brtrach-MSFT 15,351 Reputation points Microsoft Employee

    @Joao Pedro Alves It's difficult to say for sure without more information, but it's possible that the time zone settings on your Azure Cognitive Search resource or the machine making the API call are not set correctly.

    When you create an indexer in Azure Cognitive Search, you can specify a start time for the indexer to run. This start time is based on the time zone of the resource. If the time zone is not set correctly, the indexer may run at a different time than expected.

    You can check the time zone setting for your Azure Cognitive Search resource by going to the Azure portal, selecting your search resource, and then selecting "Settings" > "Time zone". Make sure the time zone is set correctly for your location.

    If the time zone setting is correct, you may want to check the time zone settings on the machine making the API call. If the time zone is not set correctly on the machine, it could be causing the API call to be made with the wrong timestamp.

    0 comments No comments

0 additional answers

Sort by: Most helpful