How to remove automapped mailbox from Outlook

X-Box-11-2021 80 Reputation points
2023-10-16T21:36:20.9866667+00:00

Hi All,

A user has an auto-mapped Outlook he had delegated access in the past.

That delegation was removed long time ago but auto-mapped mailbox still sitting in Outlook (although not expandable).

I re-checked delegated access and can confirm that nobody has delegated access to that mailbox including the affected user.

I tried to re-create Outlook profile but it didn't help.

Please advise what else I should try to remove the auto-mapped mailbox.

Microsoft Exchange Online
Outlook
Outlook
A family of Microsoft email and calendar products.
3,110 questions
{count} votes

Accepted answer
  1. Wandi Ding -MSFT 2,870 Reputation points Microsoft Vendor
    2023-10-17T06:32:48.1733333+00:00

    Hi @X-Box-11-2021 ,

    First of all, I would like to confirm how long ago the permissions were removed, because based on my experience, sometimes it may take up to 72 hours to take effect. And if it is less than the above time, you can wait again for some more time and see if there would be any difference. If it has been more than three days, I can understand that you’ve already checked the access permission, but it’s still recommended to double confirm it by running the Get-MailboxPermisson cmdlet like below, ensuring that the permission of this user has indeed been removed.

    Get-MailboxPermission -Identity <MailboxIdentity> -User <UserIdentity>
    

    If the above check shows that there is no permission and the user’s account is configured as Exchange cached mode, you can try switching to Exchange online mode and check the result.

    If the issue still persists, I’d recommend re-adding the full access permission to the user again and remove them again. Below are the basic steps for your reference:

    1 - Connect to Exchange Online PowerShell.

    2 - Run the following command to provide full access and disable automatic mapping.

    Add-MailboxPermission -Identity <MailboxIdentity> -User <UserIdentity> -AccessRights FullAccess -AutoMapping $false
    

    3 - After running the previous command, remove full access to the user's mailbox again.

    Remove-MailboxPermission -Identity <MailboxIdentity> -User <UserIdentity> -AccessRights FullAccess
    

    For more information, see remove automapping for a shared mailbox in Outlook.

    Usually, the auto-mapped mailbox can be successfully removed through the above steps. (As mentioned before, there may also be delays.)


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

     

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. Wandi Ding -MSFT 2,870 Reputation points Microsoft Vendor
    2023-10-19T01:49:14.7766667+00:00

    Hi @X-Box-11-2021 ,

    Resolved by re-delegating Full Access and removing delegated Full Access.

    Glad to know the issue has been resolved, thanks for sharing the solution so others with the same issue can easily reference it ! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others", I'll repost your solution in case you'd like to "Accept" the answer : )


    [How to remove automapped mailbox from Outlook]

    Problem symptoms:

    The auto-mapped mailbox  still exist after user delegation was removed.

    Resolution:

    By re-delegating full access and removing delegated full access.

    0 comments No comments