DNS over Https option it's disabled for users after applying GPO policy

Anonymous
2023-10-25T13:36:47.0766667+00:00

Hello guys,

I got a question and I hope I can solve this because it's an important matter for my clients.

So basically, I just added a policy on Microsoft edge browser regarding the New home page by applying a GPO for the entire organization.

After this change, the users are not able to turn on the setting regarding DNS over Http (see screenshot).
User's image

Well, I see that from GPM, from Administrative templates of Edge I can set up that setting for them and also specify a service provider, but what I want is to give them flexibility to turn that on and off whenever they want and be able to put the provider by themselves. Every change I make on GPM, the setting it's still grey out and they cannot change it.

How can I remove that and give them full control of the settings?

Thank you!!

Alex

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,205 questions
Windows
Windows
A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.
4,940 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Raina Zhao - MSFT 2,050 Reputation points Microsoft Vendor
    2023-10-26T09:02:14.97+00:00

    Hi @Anonymous ,
    As long as you applied any one of the policies, the setting "Use secure DNS to specify how to lookup the network address for websites" would be grayed out. 
    If you hover your mouse pointer over the little briefcase icon beside the greyed-out slider, you'll see a message said "This setting is turned off for managed browsers", which explains why the option isn't available. 
    Therefore, this is an expected behavior.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,

    Raina Zhao

    0 comments No comments