How to fix SSIS problem occurring after updating Visual Studio Professional 2019 to version 16.11.31

Kåre Harder Olesen 20 Reputation points

After having updated Visual Studio Professional 2019 to version 16.11.31, I cannot open any of my SSIS solutions without getting an error message that an error occurred.

In the solution explorer, it says that the package is incompatible (I had some of them opened and run just before updating to version 16.11.31), and in the main window the package content is not shown, it just informs that an error has occurred in the package (.dtsx) and it shows the path to the .dtsx file and the following information:

SSIS error

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,753 questions
SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,485 questions
{count} votes

Accepted answer
  1. Tianyu Sun-MSFT 28,576 Reputation points Microsoft Vendor

    Hello @Kåre Harder Olesen,

    Welcome to Microsoft Q&A forum.

    Please try following:

    1. If you can right-click your project in the solution explorer, then please right-click it, reload Project.
    2. Try to remove project cache by closing VS, removing the hidden .vs folder in the solution folder and reopen your project.
    3. Try to update the SSIS extension, if it’s already the latest version, then please try to uninstall and reinstall it.
    4. Try to reset VS settings by running devenv /ResetSettings in Developer Command Prompt for Visual Studio 2019 Professional.

    Best Regards,


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful