telnet/openssl connect to AFD custom domain times out after 5 seconds

Shadi 30 Reputation points

Hello all,

we have an Azure Front Door Premium on one of our customer projects. The customer has high level of incoming data, in average 200.000 per minute. Some of the devices that initiate connection to AFD don't support HTTPs and use HTTP for the connection. All the devices work as follow:

They open a connection to the custom domain defined on AFD, then they prepare their data that needs to be sent, which takes somewhere between 15 to 20 seconds. Then they transfer the data over this connection.

The problem is, some of the devices that initiate the connection using HTTP, receive a timeout after 5 seconds. I also have realized that these connections are not logged under FrontDoorAccessLog so there is no way I can investigate the issue using logs. I tried to re-create the issue myself using telnet command, and I can see that the connection is closed after about 5 seconds with the following message:

Connection closed by foreign host.

In addition to that, I also tried the openssl s_client -connect command to check the connection with TLS, and this request also closes after about 5 seconds.

As far as I know, the AFD TCP connection timeout is 61 seconds by default (I don't know if this could change or not), the keep alive timeout is 90 seconds, and my origin timeout is set to 120 seconds! So I don't see why a request should close/ timeout after 5 seconds. My guess is, since I also see no related logs, it might be that the requests don't reach my AFD profile for some reason!!

Your help is highly appreciated on the matter.


Azure Front Door
Azure Front Door
An Azure service that provides a cloud content delivery network with threat protection.
498 questions
{count} votes