GPMC error for "Security Options" after Updates 2020-09

MS Lee 61 Reputation points
2020-10-29T03:08:16.987+00:00

HI All,

I have applied new KB4580346 but it did not resolve the problem. Error "MMC has detected an error in a snap-in” still appearing.

Deleting the regkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SecEdit\Reg Values\MACHINE/Software/Microsoft/Windows/CurrentVersion/Policies/System/DontDisplayLockedUserId does not helps either.

Any help is greatly appreciated.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,397 questions
0 comments No comments
{count} votes

10 answers

Sort by: Most helpful
  1. MS Lee 61 Reputation points
    2020-11-09T01:37:37.047+00:00

    HI Daisy,

    I have tried but in vain. I do have GPO applied (with Security Policy setting configured to adhere to our security requirements) to the affected servers. I am suspecting could it be one of the configured setting but I am unsure which one. Any advices? Thank you.

    0 comments No comments

  2. Daisy Zhou 18,956 Reputation points Microsoft Vendor
    2020-11-10T08:32:04.723+00:00

    Hello @MS Lee ,

    Thank you for your update.

    1.Is the error message the same as below or different?
    38733-t5.png

    2.Would you please show us the screenshot with error message?

    3.So you suspect that what security policy you set is causing your problem, right?

    If so, which GPO object do you think it might be? If you think it might be a GPO object, if possible, you disable the group policy object, and then update the group policy to see if the problem persists.

    Or you move a machine from the specified OU to the domain, and then update the group policy to see if the problem still exists.

    If you can't operate the above operations,
    Or you can add a server to this OU to see if the problem occurs. If it happens, it may be caused by the policy, then you can check the group policy results of this test machine, and then further investigate the possible policy causing the problem.

    Hope the information above is helpful.

    Best Regards,
    Daisy Zhou

    0 comments No comments

  3. MS Lee 61 Reputation points
    2020-11-17T00:37:04.42+00:00

    Hi Daisy,

    I only have one GPO policy applied to the servers. I am hoping that you might be able to point out the exact/possible setting(s) within Security Policy might be affecting it.

    Just like down to the level of identifying that regkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SecEdit\Reg Values\MACHINE/Software/Microsoft/Windows/CurrentVersion/Policies/System/DontDisplayLockedUserId is to be delete during the interim period before 2020-10 patch resolved it.

    0 comments No comments

  4. Cheng Siyuan 1 Reputation point
    2020-11-17T23:00:22.863+00:00

    I had updated the latest patch released last 10 nov 2020. It solved the problem already

    0 comments No comments

  5. Cheng Siyuan 1 Reputation point
    2020-11-17T23:18:14.977+00:00

    I updatted thr patch November 10, 2020—KB4586830 (OS Build 14393.4046) and it fixed the gpmc error. This patch resolved the bug.

    0 comments No comments