Missing Devices in ManagedDevices List

itay4 26 Reputation points
2024-02-12T15:37:16.53+00:00

When executing a list command to retrieve all devices via the API as described on the "List managedDevices" page, I noticed that some devices were missing.
Upon investigation, I found a commonality among the missing devices: the "EAS activated" column, which should be a boolean, is empty. This is only observed in the devices that are missing from the API call. Therefore, I believe this is the cause of the missing devices.
My question is: Is this the expected behavior?

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
9,988 questions
Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,074 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Crystal-MSFT 40,701 Reputation points Microsoft Vendor
    2024-02-13T02:00:43.9033333+00:00

    @itay4 , Thanks for posting in Q&A. Based on my checking, in my environment, the "EAS activated" is with a boolean value. For your scenario the device without "EAS activated" value not showing when we check via List managedDevices, I suggest open case to check in the background to look into the issue. Here is a link with the steps to open case for your reference:

    https://learn.microsoft.com/en-us/mem/get-support

    Thanks for your understanding.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments