Cannot drag and drop files in SharePoint Online document library

WTurk 0 Reputation points
2024-03-08T10:56:32.7633333+00:00

I’m testing the drag-and-drop functionality in a SharePoint document library, but when I tried to drag and drop a new version of a document, I kept getting an error message that says that the file is “locked for shared use… by ME (!)”. The new version isn’t checked out or opened anywhere and I certainly haven’t “locked” it in any other way. I’ve since discovered that this is a well known bug (see here and here). I have tried a few workarounds suggested on those forums but the only thing that worked was going back into the document, checking it out and then back in, and saving it again. This is surely an insane solution - and at the moment you can only drag and drop once and cannot update the file with a newer version of the same file – ever. Any advice would be appreciated.

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,558 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Yanli Jiang - MSFT 21,361 Reputation points Microsoft Vendor
    2024-03-11T07:24:53.08+00:00

    Hi @WTurk ,

    I'm sorry you're having such a problem. Because things are random, I can't reproduce them. After research, the reasons for this situation are very complicated, and there is currently no better way to solve it. You can contact Microsoft directly to solve the problem, or we recommend that you go to the Microsoft 365 admin center to report this issue.

    User's image

    If you have any better methods, please share them here.

    Have a nice day!


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.