New Snowflake connector doesn't work with empty Snowflake tables containing Floats

Max Kirkman 20 Reputation points
2024-03-14T22:34:52.19+00:00

Hi,

I have switched to the new Snowflake connector from the now legacy Snowflake connector.

Operations in Data Factory were working before switching to this new Snowflake connector. I am now getting the following error when I try to interact with an empty Snowflake table that contains Float columns:

image

Any help would be greatly appreciated :)

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,449 questions
{count} votes

Accepted answer
  1. Harishga 3,170 Reputation points Microsoft Vendor
    2024-03-16T02:06:44.86+00:00

    Hi @Max Kirkman
    Welcome to Microsoft Q&A platform and thanks for posting your question.

    I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others " I'll repost your solution in case you'd like to accept the answer.

    ASK
    I have switched to the new Snowflake connector from the now legacy Snowflake connector.

    Operations in Data Factory were working before switching to this new Snowflake connector. I am now getting the following error when I try to interact with an empty Snowflake table that contains Float columns:

    Solution:
    Manipulating a legacy Snowflake dataset to use the new Snowflake connector causes the error. I didn't see this initially because other tables came through correctly, including empty tables without float data types.

    If I missed anything please let me know and I'd be happy to add it to my answer, or feel free to comment below with any additional information.

    If you have any other questions, please let me know. Thank you again for your time and patience throughout this issue.


    Please don’t forget to Accept Answer and Yes for "was this answer helpful" wherever the information provided helps you, this can be beneficial to other community members.


1 additional answer

Sort by: Most helpful
  1. Max Kirkman 20 Reputation points
    2024-03-15T22:13:54.2+00:00

    Hi,

    Manipulating a legacy Snowflake dataset to use the new Snowflake connector causes the error. I didn't see this initially because other tables came through correctly, including empty tables without float data types.

    Thank you for the help guys :)

    0 comments No comments