Update calendar permissions.

IniobongNkanga-8038 236 Reputation points
2024-03-22T20:16:52.91+00:00

Hello 

 

Please i need your help on this issue. 

 

One of our users is not able to book an appointment on her calendar.  But when she tried to create, edit or do anything on her calendar it does not show up on the next person calendar. 

 

So therefore, i would like to know how to grant her a Calendar editor permission.

 

Also, we have tried using the PowerShell command, but it does not work. 

Microsoft Exchange Online
Outlook
Outlook
A family of Microsoft email and calendar products.
2,886 questions
Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,855 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Yuki Sun-MSFT 40,781 Reputation points
    2024-03-25T02:11:15.64+00:00

    Hi @IniobongNkanga-8038

    One of our users is not able to book an appointment on her calendar. But when she tried to create, edit or do anything on her calendar it does not show up on the next person calendar.

    I read through the post but not quite clear about the situation. Could you try to elaborate it a bit more so that we can understand better about the issue?
    Is it that the user in question needs to manage the calendar of another person, but when she tried to create or edit items on that calendar from her end, the changes would not reflect to the owner's calendar?

    i would like to know how to grant her a Calendar editor permission. Also, we have tried using the PowerShell command, but it does not work.

    What command did you used and was there any error message when running that command?

    Given current situation, please connect to Exchange Online PowerShell and then run the command below to check the current permissions:

    Get-MailboxFolderPermission -Identity User1@contoso.com:\Calendar
    
    

    Remove the existing permissions for the problematic user(let's say user2):

    Remove-MailboxFolderPermission -Identity User1@contoso.com:\Calendar -User User2@contoso.com
    
    

    Add the Editor permission using command below:

    Add-MailboxFolderPermission -Identity User1@contoso.com:\calendar -user User2@contoso.com -AccessRights Editor
    
    

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments