How can I connect to Salesforce from Data Factory if I cannot input the security token - I get an invalid Session ID error?

Erik Avilés Castilla 0 Reputation points
2024-03-25T09:56:03.1666667+00:00

How can I connect to Salesforce from Data Factory if I cannot input the security token - I get an invalid Session ID error? Before, I could connect easily using my email, password and security token. However, with the new display i need to us the Salesforce app customer key and secret - this is fine since I can connect to the linked service of Salesforce. However, after that no objects are shown and a session invalid for the API connection is displayed. I believe it is due to the fact that the connection needs the security token but I cannot input this anywhere. Please can i get some help on this? I am struggling to find someone to look into this and it is affectig quite negatively our company's performance.

Thanks in advance

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,493 questions
{count} votes

1 answer

Sort by: Most helpful
  1. phemanth 5,645 Reputation points Microsoft Vendor
    2024-04-02T07:56:05.3633333+00:00

    @Erik Avilés Castilla Welcome to Microsoft Q&A platform and thanks for posting your question.

    I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others "I'll repost your solution in case you'd like to accept the answer.

    Ask: How can I connect to Salesforce from Data Factory if I cannot input the security token - I get an invalid Session ID error? Before, I could connect easily using my email, password and security token. However, with the new display i need to us the Salesforce app customer key and secret - this is fine since I can connect to the linked service of Salesforce. However, after that no objects are shown and a session invalid for the API connection is displayed. I believe it is due to the fact that the connection needs the security token but I cannot input this anywhere. Please can i get some help on this? I am struggling to find someone to look into this and it is affectig quite negatively our company's performance.

    Solution: my Salesforce team was not configuring properly the MFA access/restrictions. All resolved now thanks

    If I missed anything please let me know and I'd be happy to add it to my answer, or feel free to comment below with any additional information.

    If you have any other questions, please let me know. Thank you again for your time and patience throughout this issue.


    Please don’t forget to Accept Answer and Yes for "was this answer helpful" wherever the information provided helps you, this can be beneficial to other community members.

    0 comments No comments