Azure Stack HCI 23H2 deployment fails due to a space in the custom location tag

Robin Lee 0 Reputation points
2024-03-26T09:33:41.6066667+00:00

The deployment of my cluster failed on the step "Deploy Arc infrastructure components". This is because I entered two words separated by a space as a tag. It thinks the second word is a parameter.

Now I can't work out how to correct this.

Type 'DeployArb' of Role 'MocArb' raised an exception: Exception while installing ARB in step [DeployArb:Calling Install-ArcHciMgmt] Correlation ID: 9b99890a-0d0a-497f-9ca7-3f27e2d826de. C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2\wbin\az.cmd customlocation show --subscription 35eb6fc0-32b6-4f43-9dea-7954698477f9 --resource-group Contoso --name Gotham City --only-show-errors returned a non empty error stream [ERROR: unrecognized arguments: City System.Management.Automation.RemoteException Examples from AI knowledge base: https://aka.ms/cli_ref Read more about the command in reference docs] at [at Invoke-ArcHciAzCommandLine, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 3046 at Invoke-ArcHciAzCommand, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 2972 at Get-ArcHciCustomLocation, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 4628 at Remove-ArcHciCustomLocation, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 4059 at Install-ArcHciMgmt, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 5582 at DeployArbInternal, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbHelper.psm1: line 1444 at DeployArb, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbLifeCycleManager.psm1: line 131 at <ScriptBlock>, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 127 at Invoke-EceInterfaceInternal, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 123] at at Remove-ArcHciCustomLocation, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 4096 at Install-ArcHciMgmt, C:\Program Files\WindowsPowerShell\Modules\ArcHci\0.2.44\ArcHci.psm1: line 5582 at DeployArbInternal, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbHelper.psm1: line 1444 at DeployArb, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbLifeCycleManager.psm1: line 131 at <ScriptBlock>, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 127 at Invoke-EceInterfaceInternal, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 123 Command Arguments ------- --------- DeployArbInternal {Parameters=CloudEngine.Configurations.EceInterfaceParameters} {} <ScriptBlock> {CloudEngine.Configurations.EceInterfaceParameters, MocArb, DeployArb, C:\NugetStore\Micr... Invoke-EceInterfaceInternal {CloudDeploymentModulePath=C:\NugetStore\Microsoft.AzureStack.Solution.Deploy.CloudDeploy... at Trace-Error, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\Common\Tracer.psm1: line 63 at DeployArbInternal, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbHelper.psm1: line 1512 at DeployArb, C:\NugetStore\Microsoft.AzureStack.MocArb.LifeCycle.1.2402.0.16\content\Scripts\MocArbLifeCycleManager.psm1: line 131 at <ScriptBlock>, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 127 at Invoke-EceInterfaceInternal, C:\CloudDeployment\ECEngine\InvokeInterfaceInternal.psm1: line 123

Azure Stack HCI
Azure Stack HCI
A hyperconverged infrastructure operating system delivered as an Azure service that provides security, performance, and feature updates.
263 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Sina Salam 3,396 Reputation points
    2024-03-27T13:55:54.5766667+00:00

    Hello Robin Lee

    Welcome to the Microsoft Q&A and thank you for posting your questions here.

    Sequel to your questions, I understand that your the deployment failed because there was a space in the custom location tag and you need to fix this.

    After reviewing the error message you posted, the error message indicates that the second word after the space is being interpreted as a parameter instead of part of the tag. To correct this issue, you need to ensure that the custom location tag does not contain any spaces.

    You can resolve and correct the issue by the following steps:

    1. Determine where the custom location tag is specified in your deployment configuration. Look for any instances where a tag is provided, particularly those related to the custom location.
    2. Modify the custom location tag to ensure that it does not contain any spaces. If you need to use multiple words, consider using underscores (_) or hyphens (-) instead of spaces to avoid confusion with parameters.

    After you have done the above then, update your deployment configuration with the corrected tag and ensure you redeploy the Azure Stack HCI with the corrected custom location tag.

    Everything should work fine, otherwise, there are other information you do not share.

    I hope this is helpful! Do not hesitate to let me know if you have any other questions.

    Please remember to "Accept Answer" if answer helped, so that others in the community facing similar issues can easily find the solution.

    Best Regards,

    Sina Salam


  2. Robin Lee 0 Reputation points
    2024-04-05T08:08:24.7933333+00:00

    I'm told the custom location name will accept spaces from build 2405. Until then, in this particular scenario, the only viable option is to redeploy the environment and be sure to exclude a space.