password synchronisation issues

David Johnson 0 Reputation points
2024-04-08T01:48:00.4566667+00:00

Modern authentication a couple of weeks ago. Since then we are prompted for passwords in Outlook randomly on different computers. We are running Outlook 2016, 2019 and M365 and Windows 10/11 on all machines.

Exchange | Hybrid management
Exchange | Hybrid management
The administration of a hybrid deployment that connects on-premises Exchange Server with Exchange Online, enabling seamless integration and centralized control.
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  1. Faery Fu-MSFT 19,836 Reputation points Moderator
    2024-04-08T07:32:24.51+00:00

    Hi @David Johnson ,

    I understand that you’ve been experiencing password prompts in Outlook after enabling Modern Authentication a few weeks ago.

    Cause:

    When Outlook connects to Microsoft 365 using RPC, it limits its authentication choices to schemes supported by RPC. But the authentication schemes don't include Modern Authentication.

    Resolution:

    To resolve this issue, we’ll create a registry key to force Outlook to use a newer authentication method for web services (such as EWS and Autodiscover). Specifically, we’ll enable Modern Authentication:

    Important: Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    1. Exit Outlook.
    2. Press Windows Key + R to open a Run dialog box. Type regedit.exe, and then press Enter.
    3. In Registry Editor, locate and click the following registry subkey:
         HKEY_CURRENT_USER\Software\Microsoft\Exchange
         
      
    4. On the Edit menu, point to New, and then click DWORD Value.
    5. Type AlwaysUseMSOAuthForAutoDiscover, and then press Enter.
    6. Right-click AlwaysUseMSOAuthForAutoDiscover, and then click Modify.
    7. In the Value data box, type 1, and then click OK.
    8. Exit Registry Editor.

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