Error "Resource validation failed" at Azure OpenAI Studio

shota sato 0 Reputation points
2024-05-01T03:51:49.25+00:00

Problem

I attempted to implement Azure on your data.

An error occurs in the "Add your data" section of the Azure OpenAI Studio.

I would appreciate your guidance.

Error message

Resource validation failed. Provided search resource does not exist or credentials are invalid.

User's image

Steps

  1. Created Azure OpenAI.
    1. Deployed gpt-4-32k and text-embedding-ada-002.
    2. Enabled Managed Identity.
    3. Created roles.
      1. User's image
  2. Created Azure AI Search.
    1. Enabled Managed Identity.
    2. Created roles.
      1. User's image
  3. Created Azure Blob Storage.
    1. Enabled Managed Identity.
    2. Created roles.
      1. User's image
    3. Configured CORS.
      1. Allowed all inbound and outbound forGET method.
    4. Created a container.
      1. Stored CSV files.
  4. Attempted to "bring your own data" in OpenAI Studio.
    1. Selected the option to use Blob Storage.
    2. Selected resources from steps 1 to 3.
    3. Enabled "Vector Creation".
    4. Completed the setup.
      1. User's image
  5. Error occurred (error details mentioned above)

Notes

All resources belong to the same resource group.

The resource group and resources are in the same region (Australia East).

My user rlole is "Global Administrator".

I followed official guidences.

Azure AI Search
Azure AI Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
741 questions
Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,469 questions
Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,251 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. shota sato 0 Reputation points
    2024-05-01T09:54:30.7566667+00:00

    Resolved. I forgot to set "Both" at api access setting at Azure AI Search.


  2. ajkuma 22,766 Reputation points Microsoft Employee
    2024-05-01T10:03:23.22+00:00

    Summarizing the answer shared by shota sato.

    Scenario: Attempting  to implement Azure on your data. An error occurs in the "Add your data" section of the Azure OpenAI Studio

    Issue: Error message : Resource validation failed. Provided search resource does not exist or credentials are invalid.

    Resolution: To set "Both" at api access setting at Azure AI Search.

    shota sato, Thanks for sharing the solution that worked for you with the community.

    0 comments No comments