Microsoft Authenticator stuck in a loop/not working on new device

Newall Sarah 25 Reputation points
2024-05-13T05:44:48.3366667+00:00

Hi

I am having huge trouble getting my Microsoft authenticator app to work on my new iPhone. It worked perfectly on my old iPhone.

Unfortunately I did not enable 1Cloud backup so recovery of my account is not an option.

Essentially, authenticator is asking me to use Authenticator itself to enter authentication codes, which is not possible. I do not get 'pop up' screens to enter codes as I did previously.

I cannot access my work emails on my phone and it's causing huge issues. I have also tried signing into Microsoft 365 on my work laptop to try and fix the issue, and it just send me back to Authenticator again, which cannot . Codes requested on my laptop do not appear in Authenticator.

I have deleted an reinstalled authenticator and tried to set up the accounts again.

Does anyone have a clear method of fixing this issue?

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
5,623 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. José Viveiros Filho 0 Reputation points
    2024-05-13T18:20:17.2+00:00
    0 comments No comments

  2. Fabio Andrade 650 Reputation points Microsoft Employee
    2024-05-13T23:05:48.3+00:00

    Hi @Newall Sarah

    Thanks for reaching out to Microsoft Q&A

    The article provided above will help, but what you really need to do is to delete the Authenticator App from the Authentication Methods blade under your user configuration as below. You'll need to have Admin permissions in order to delete the method though:

    User's image

    Let us know if you have any questions.

    Thanks,

    Fabio


  3. Navya 4,395 Reputation points Microsoft Vendor
    2024-05-15T16:27:22.02+00:00

    Hi @Newall SarahThank you for posting this in Microsoft Q&A.

    We have 2 options to resolve the issue.

    1.Global administrator or Authentication Administrator role can delete the Microsoft Authenticator app for your account. Do you have another Global admin account in your tenant? if you have another admin account, make sure that account has correct privileges to perform this change "Require re-register multifactor authentication"

    Here are the steps:

    • Sign in to the Microsoft Entra admin center
    • On the left, select identity > Users > All users.
    • Choose your account->select Authentication methods and click "Require re-registration for MFA" - It deletes the following authentication methods from this user: phone numbers, Microsoft Authenticator apps and software OATH tokens. If needed, the user is requested to set up a new MFA authentication method the next time they sign in.

    For your reference: Manage user authentication options

    2.Go to the Security info page, find the device you want to delete and try to delete.

    If you are the only global admin on the account and are blocked entirely, you can reach out to our support team. You can look into below article to get support numbers depending on your country.

    https://support.microsoft.com/en-us/topic/global-customer-service-phone-numbers-c0389ade-5640-e588-8b0e-28de8afeb3f2

    Hope this helps. Do let us know if you any further queries.

    Thanks,

    Navya.

    If the answer is helpful, please click "Accept Answer" and kindly "upvote" it.