Group Policy setting Cached Exchange Mode not working.

Srinivas 0 Reputation points
2024-05-24T11:31:00.9333333+00:00

Hi All,

I am struggling to set outlook Exchange Cached Mode to 6 Month Group policy.We have Citrix Environment users will connect to Windows 2019 server with RDS license's multiple connections, we have FSlogix configured. User will use Outlook and most of the users Mailbox size is more than 35 GB. so we want to implement Exchange Chace mode for 6 months to reduce the OST file size. we are using 'Microssoft Office LTSC Professional Plus 2021 -en-us'

we applied the policy

We applied Exchange Cached mode from Group Policy.User's image

We applied the below configuration to 6 months User's image

from Group Policy Management 'Select Cached Exchange Mode sync settings for profiles' to ALL it is not getting applied on outlook too.

User's image

Any help is much appreciated thank you.

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,053 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,426 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Faery Fu-MSFT 17,716 Reputation points Microsoft Vendor
    2024-05-28T06:58:51.18+00:00

    Hi @Srinivas ,

    I understand that you’re having trouble applying the ‘ALL’ setting for Cached Exchange Mode sync in Outlook via Group Policy Management. Here are a few things you could check:

    1. Group Policy Update: After changing the Group Policy, you need to ensure that the policy is updated on the client machines. You can do this by running the gpupdate /force command in the command prompt on the client machines.
    2. Registry Settings: You can also check the registry settings on the client machines. The Cached Exchange Mode settings are stored in the registry in the HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode key.
    3. GPMC Display Issue: There is a known issue where the Group Policy Management Console (GPMC) does not differentiate between the ‘One week’, ‘Two weeks’, or ‘All’ options for the Cached Exchange Mode Sync Setting policy, and it always shows ‘Three days’ when you reopen the management console. However, this only affects the way that the setting is displayed in GPMC, and the Cached Exchange Mode Sync Setting policy should work correctly as it’s configured.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.