IE "noframemerging" option not working

Zhu, Ligong 100 Reputation points
2024-06-04T21:21:17.0766667+00:00

Hi,

We have a Java/JSP/Servet web application and launch a new Edge instance in IE mode with "-noframemerging" option to make sure each window has its own session to prevent data mixed problem.

But when we start our application from the same source twice very quickly, it often launches two windows with same session id, and their data is mixed. If we wait until the first application loading to be completed then click again to start the second application, it always works in its own session and no session data mixed.

Is there anyway you can think of to fix this and prevent session merger in Edge with IE mode?

Thanks.

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,208 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Jinxin Wang (Shanghai Wicresoft Co Ltd) 1,145 Reputation points Microsoft Vendor
    2024-06-05T02:50:27.1233333+00:00

    Hi @Zhu, Ligong,

    I read your description, but as far as I know, this 'noframemerging' option is applicable for IE11, not for IE mode, so it will not work.

    You can use the 'no-merge' option in IE mode. If you configure this option, when a new browser window is launched from an IE mode application, it will be in a separate session, like the no-merge behavior in IE11. For more detailed information, you can refer to the link.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best regards,

    Jinxin Wang