Permission Issue while setting up amulet project

Ilgee Hong (CSI INTERFUSION INC) 20 Reputation points Microsoft Vendor
2024-06-18T21:56:18.0633333+00:00

Hello,

I'm encountering a permission issue while setting up the Amulet project using Command Prompt. I can see from the Azure Storage page that I am already assigned the Storage Table Data Contributor role on my storage account, however, when I try to have access to the storage account using Command Prompt, I receive the following error message:

"You don't have permission to perform this operation. Ensure that you have the Storage Table Data Contributor role on the storage account. This change is due to the move to disable access key-based authentication. See Amulet Documentation and Microsoft Azure Keyless for more information."

Could you help me resolve this issue?

Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,925 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sumarigo-MSFT 45,406 Reputation points Microsoft Employee
    2024-06-24T12:58:17.1333333+00:00

    @Ilgee Hong (CSI INTERFUSION INC) Welcome to Microsoft Q&A Forum, Thank you for posting your query here!

    Firstly, Apologies for the delay in response here!

    Based on the error message, this article states how to Assign an Azure role for access to table data

    The error message you are seeing indicates that you do not have the necessary permissions to access the storage account using Command Prompt. Even though you have been assigned the Storage Table Data Contributor role on the storage account, it is possible that the role assignment has not yet taken effect.

    Here are a few things you can try to resolve the issue:

    1. Wait for the role assignment to take effect: It can take some time for the role assignment to take effect. Wait for a few minutes and try again.
    2. Check the role assignment: Double-check that you have been assigned the Storage Table Data Contributor role on the storage account. You can check this by going to the storage account in the Azure portal and clicking on "Access control (IAM)" in the left-hand menu. Make sure that your user account is listed as having the Storage Table Data Contributor role.
    3. Check the storage account name: Make sure that you are using the correct storage account name in the Command Prompt. Double-check the spelling and make sure that the storage account exists in the same subscription and region as the Command Prompt.
    4. Use Azure AD authentication: The error message you are seeing indicates that access key-based authentication has been disabled. You can try using Azure AD authentication instead. To do this, you will need to create a service principal and assign it the necessary permissions to access the storage account. You can then use the service principal's credentials to authenticate to the storage account in the Command Prompt.

    Additional information: Check the Amulet Documentation for any specific setup instructions, especially regarding the move to disable access key-based authentication.

    Look into Microsoft Azure Keyless, which might provide alternative authentication methods that are compliant with the new security measures.

    Storage Account Contributor Permits management of storage accounts. Provides access to the account key, which can be used to access data via Shared Key authorization.

    There is detailed information on permission and access in this Q&A thread, which provide some idea on your query.

    Please let us know if you have any further queries. I’m happy to assist you further.     


    Please do not forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful