How to enroll AVD hosts for patching and updates via intune after provisioning?

EDWARD REYESARROYO 5 Reputation points
2024-06-20T00:51:53.3933333+00:00

I have provisioned some domain-joined AVD hosts, and Intune enrollment was not selected during provisioning. What is the process to enroll them for patching and updates via Intune?

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,450 questions
Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
4,742 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Xenia-MSFT 1,030 Reputation points Microsoft Vendor
    2024-06-20T07:51:43.7766667+00:00

    @EDWARD REYESARROYO Thanks for posting in our Q&A.

    Currently, only support enrollment to Intune during deployment for session hosts (i.e. for new hosts).

    Based on my research, I didn't find a method to enroll existing AVD host to intune.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. vipullag-MSFT 26,016 Reputation points
    2024-06-21T01:05:06.48+00:00

    Hello EDWARD REYESARROYO

    Welcome to Microsoft Q&A Platform, thanks for posting your query here.

    If the session hosts are hybrid joined, you can do this via GPO. You should use device credential.

    Hope this helps.

    If the suggested response helped you resolve your issue, please 'Accept as answer', so that it can help others in the community looking for help on similar topics.

    0 comments No comments

  3. EDWARD REYESARROYO 5 Reputation points
    2024-06-24T13:17:40.35+00:00

    Working on hybrid AD Connect to see if that works "maybe" Ill post the result here so the community see it.