Failed install of grpc in Azure App Service

Jingo Rodriguez 0 Reputation points
2024-06-24T15:30:25.4566667+00:00

Hi everyone,

I have tried installing grpc thru web ssh of azure, it works fine when i do it locally on my end, but installing on the server gave me errors when installing it.

Getting Failed make, /tmp/pear/temp/pear-build-rootqNPiwy/grpc-1.64.1/libtool: line 1290: src/core/channelz/channel_trace.loT: No such file or directory mkdir src/core/channelz/.libs

mkdir: cannot create directory 'src/core/channelz/.libs': No such file or directory make: *** [Makefile:210: src/core/channelz/channel_trace.lo] Error 1 ERROR: `make' failedAlso tried building the grpc, but doesn't seem to work properly as the web ssh somehow gets resets. Also gets this note on the web sshNote: Any data outside '/home' is not persisted

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,372 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SnehaAgrawal-MSFT 20,471 Reputation points
    2024-07-10T05:11:05.59+00:00

    Update- Issue is resolved and original poster has managed to install it by using screen and created the folder while it was running pecl install grpc.

    Glad that you were able to resolve your issue and I appreciate your effort in sharing the solution.

    Your contribution will undoubtedly assist others facing similar challenges.

    As the [Microsoft Q&A community follows a policy where the question author cannot accept their own answer] {https://learn.microsoft.com/en-us/answers/support/accept-answer} ,

    I've reposted your solution for wider audience.

    Feel free to consider "Accepting" the answer.

    0 comments No comments