After running the windows 11 installation assistant getting error code 0xc190010d, The installation process was launched with an invalid command line argument.

Brumbaugh, Will 0 Reputation points
2024-06-25T19:52:33.59+00:00

I have been trying to do an in-place upgrade to win 11 22h2 I am using Intune update rings with feature updates. When the update runs i get an error code 0xC190010d, invalid command line arguments. I then tried to install the updates using PowerShell module and that got the same failure. I then tried using the update assistant which is installing win 11 23h2 and again same error.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,966 questions
Microsoft Intune Updates
Microsoft Intune Updates
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Updates: Broadly released fixes addressing specific issue(s) or related bug(s). Updates may also include new or modified features (i.e. changing default behavior).
92 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Xenia-MSFT 950 Reputation points Microsoft Vendor
    2024-06-26T01:46:07.5966667+00:00

    @Brumbaugh, Will Thanks for posting in our Q&A.

    From your description, this issue also occurs when you use the update assistant. It seems this issue not related to intune. To get more information, I will add windows 11 tag.

    Based on my research, I found someone shared a method to fix this error. Please refer to the following link:

    https://www.thewindowsclub.com/fix-windows-upgrade-error-codes-0xc190010d-0xc190010a

    Note: Non-Microsoft link, just for the reference.

    Hope it will help.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments