Server 2016 Displays Driver Name Of Shared Printer Instead Of Share Name

Joe Hinkle 141 Reputation points

I have an issue with a HP M605 and HP M425 drivers that are not displaying correctly in server 2016. I have verified that the drivers work correctly on Win 10.

The problem started yesterday. No changes were made to the RDP server they're using or the print server that controls this printer.

So far I've:

  1. Made sure that the attributes are correct in ADSI Edit. Because it works on Win 10 I didn't see any reason to change anything.
  2. Verified it's not a user, gpo, or print server issue by creating a test user, test printer, test ou, and test printer all from scratch. The problem continues on Server 2016.
  3. Verified AD replication is working correctly.
  4. Verified the printer is listed in AD. I typically just share them but I listed it for testing.
  5. The correct share name shows up in the printer properties. The name the user sees is the driver.
  6. Unshared the printer, reset print spooler, shared it.
  7. Renamed printer
  8. Tested printer by manually connecting via print server and GPO. Same problem shows up.

There is a recent update waiting to install. I'm going to run that tonight and reboot. I'm at the end of my rope here and I can't seem to find any good info on Server 2016 printer name issues. Has anyone seen this before?

I'm also going to run updates on our print server and reboot it tonight as well.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,220 questions
Windows Server Printing
Windows Server Printing
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Printing: Printer centralized deployment and management, scan and fax resources management, and document services
611 questions
{count} vote

Accepted answer
  1. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,716 Reputation points Microsoft Vendor


    I have done a lab test and found it is a by design behavior on server 2016 if you add a shared printer with the specific driver. The printer name will display as the driver name.

    But if the printer driver is a universal driver (such as HP Color LaserJet 1600 Class Driver) which is listed in the driver list, then it will display the printer name correctly.

    So, this problem should come from the printer driver. You can try another universal driver for a test.




    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    0 comments No comments

13 additional answers

Sort by: Most helpful
  1. Bill Hart 1 Reputation point

    I have been struggling with this issue since Win 10 2004. Has anyone made any progress?
    I have tested this to death, and have concluded much of what you all have been saying:

    1. Since 2004 was released, my Ricoh V3 drivers would take 20 minutes to roll out and required a couple reboots it seemed. It was like they were installing partially or timing out.
    2. In (Modern UI) Settings->Printers & Scanners, all my Ricohs show as the model number and not the name.
    3. If I try to go into the properties or try to set the default printer (Modern UI), I get errors.
    4. If I go to (Legacy UI) Control Panel -> Devices and Printers, I can set the default and go into properties, but the names are all screwed up until I select a default, then it suddenly changes to the printer name. Funny thing however is that if I set a different one to default, the previous default name goes back to model of the printer.
    5. All legacy apps show the printer name just fine (thankfully), so when the users print in Excel, they can read the printers just fine.
    6. Yes, manually changing all the Ricoh printers ConfigFlag from 400 to 0 in the PRINTENUM folder (users local registry), suddenly fixes the printer names, and full functionality is restored to the printer in the Modern UI.

    One thing I have observed though and question is this:
    When I try to deploy the printers via GPO, the event log ID is get is 513, source PrintService, and is states that the group policy is unable to add per computer connection \Server\Printer Name. Now please pay attention to what I just wrote there, as you all know, when browsing for printers, it is always \server\share name, not printer name. That might be a clue.

    When I go into the print server (server 2008R2 and now as well, since we went to 2019) and share a new printer, the GPO entry that it creates on the DC is \server\printer name, not \server\share name.

    So for giggles, I went to my local Explorer, and typed in \server\printer name, and it cannot find it - makes sense, because that is not how UNC works, but if I go to \server\share name, it works. (That was just a test to see if MS added new functionality to 2004 and higher.

    So I am not surprised that the deployment fails. The question is this however, why is this happening and how do we fix this? I cannot find any method of changing that GPO value to be \server\share name because the GPO (computer config\policies\windows settings\deployed printers) cannot be edited at all, NOR can I manually edit or add the printer using the print server GP deployment method.

    Disclaimer: I have no idea how this all worked previously, when everything worked just fine, so I have no idea if the GPO always used \server\printer name or \share name, because I never had to dissect this stuff at this level until now. Does anyone have any historical knowledge on this? Am I on to something here?

    0 comments No comments