Hello @Manish Aggarwal,
I'm glad that you were able to resolve your issue and thank you for posting your solution so that others experiencing the same thing can easily reference this! Since the Microsoft Q&A community has a policy that "The question author cannot accept their own answer. They can only accept answers by others ", I'll repost your solution in case you'd like to "Accept " the answer.
Issue: Azure Windows VM login related logs not getting ingested in MS SENTINEL logs
Solution: Resolved by @Manish Aggarwal, following below steps:
-- VM is not connected to the "Log Analytics" -- The monitoring agent was not active in the windows VM. -- Then in the Content Hub -- Data Connectors -- added "Windows Security Events", and then selected 2 for install "Security Events Via Legacy Agent" and "Windows security events via AMA". -- Now, disconnect and once again do a login with 2 (for example) wrong password and then with correct password, and wait for a few minutes. -- Seems like it shows now as wrong attempt from below screenshot (error code == 4625 "failed logon attempt") -- Go to Windows Sentinel -- Logs and run below: Heartbeat -- and SecurityEvent | where EventID == 4625 -- Now you will see the failed login attempts in your specified time (in the filter).
If you have any other questions or are still running into more issues, please let me know. Thank you again for your time and patience throughout this issue.
Please remember to "Accept Answer" if any answer/reply helped, so that others in the community facing similar issues can easily find the solution.
Thanks,
Raja Pothuraju.