The error you encountered "code": "BadRequest", "message": "BAD_REQUEST: Account per user limit exceeded, each user is only allowed to join 60 accounts"
indicates that your Azure account has exceeded the maximum limit of 60 Databricks accounts for a single user. Even though you mentioned being part of only three instances, this limit can be affected by several factors:
Possible Causes:
- Inactive or Orphaned Accounts - You may have been part of other Databricks accounts in the past, which are still active.
- Pending Invitations - Even accounts you were invited to (but did not accept) may count toward the limit.
- Multiple Workspaces - A single Databricks account can have multiple workspaces, each counting towards the limit.
- External User Configuration - If your user was set as an external user (guest user) in Azure Active Directory (AAD), this may have caused the issue.
How to Resolve:
- External user to Internal user - This issue can be resolved by converting your Azure AD user type from an external user (guest) to an internal user.
- Review Your Account Memberships - Check all your active Databricks accounts in each Azure AD tenant you are part of.
- Remove Unnecessary Accounts - Work with the administrators of those accounts to remove your membership where not needed.
For additional information, please refer: Convert external users to internal users (Preview)
Please refer to the similar thread on the Microsoft Q&A forum that discusses the same issue: https://learn.microsoft.com/en-us/answers/questions/1922324/databricks-workspace-deployment-failed-with-badreq
I hope this information helps. Please do let us know if you have any further queries.
If this answers your query, do click Accept Answer
and Yes
for was this answer helpful. And, if you have any further query do let us know.
Thank you.