Azure app services: Set max_execution_time in php settings

Jean BIEMEWOU 1 Reputation point
2021-01-18T14:55:32.137+00:00

Hello.
I have a php script to import the data into the database. And I would like to import if possible 10000 lines. Except that I'm blocked by the timout because max_execution_time=300 in php.ini
So I did some research and among the solutions I tried the following:
1- <IfModule mod_php7.c> php_value max_execution_time 0 </IfModule> in .htaccess (pulic folder)

2- ini_set('max_execution_time', 0); in my controller (I use Laravel)

3- https://learn.microsoft.com/en-us/azure/app-service/configure-language-php?pivots=platform-windows#customize-phpini-settings

4- I combined all these solutions

None of these ideas work.
Please, does anyone have an idea of what to do?

Thank in advance

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,017 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ryan Hill 26,241 Reputation points Microsoft Employee
    2021-01-19T17:28:24.823+00:00

    Hi @Jean BIEMEWOU ,

    I noticed you asked the same question over on stackoverflow and have received an answer. If modifying the .htaccess doesn't work for you, please let me know by commenting down below.

    Regards,
    Ryan