Unable to Configure Networking on Nested Setup

Michael Tughan 16 Reputation points
2021-01-19T20:13:42.35+00:00

I am attempting to set up Azure Stack HCI cluster for evaluation by following the guide at https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/README.md and https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/README.md. I have been able to proceed through parts 1-3 and have my management VM, my domain controller, and 2 nodes set up, but am getting stuck during part 4.

In part 4, creating the cluster (https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/steps/4_AzSHCICluster.md), I can breeze through the Get started section; everything configures fine there. When I get to Networking, I am able to set up everything until the Define networks step. There, I have left Ethernet 2 alone, and set up Ethernet 3 to be Storage 1 on each node, and Ethernet 4 to be Storage 2 on each node. Regardless of how I set up the IP addresses (see below), I cannot get the cluster report to generate and proceed to the actual cluster creation.

After clicking Apply and Test, it applies changes to all network adapters, tests connectivity, attempts to create VSwitches for each interface (even though I selected to only create a VSwitch for the compute NICs in the steps previous, as described in the guide), and then attempts to test the cluster network. The first time I try it, I get an error after saying, "We couldn't configure and test network adapters. Please try again. Error: Failed to create a cluster network test report." If I just click Apply and Test again, it goes through the same steps as above, but hangs forever when testing the cluster network.

I have tried the following IP ranges, with node 1 being assigned device IP 1 (e.g., 10.10.10.1 for 10.10.10.0/24) and node 2 being assigned device IP 2:

  • Ethernet 2: APIPA (169.254.0.0/16 [it says 24 in the table in the guide, but this is incorrect; the 16 in the screenshot is correct]); Storage 1: 10.10.10.0/24; Storage 2: 10.10.11.0/24
  • Ethernet 2: APIPA (169.254.0.0/16); Storage 1: 192.168.10.0/24; Storage 2: 192.168.11.0/24
  • Ethernet 2: 192.168.8.0/24; Storage 1: 192.168.10.0/24; Storage 2: 192.168.11.0/24

I've tried ranges in 192.168.0.0/16 because my company also uses addresses in the 10.0.0.0/8 range and I wanted to make sure that it wasn't conflicting with the setup, but I get the same results.

I haven't been able to find anything about why the operations are failing, or what I can do to possibly resolve it. Can anyone help me out, either with some step-by-step guides or some pointers where I can even get some logs? Event Viewer doesn't have anything pertinent (only showing that it made a POST requests for a PowerShell command without logging the actual PowerShell run, as well as a telemetry call showing statuses being polled), and I haven't been able to find any logs on disk (checked C:\Program Files\Windows Admin Center as well as C:\ProgramData).

Azure Stack HCI
Azure Stack HCI
A hyperconverged infrastructure operating system delivered as an Azure service that provides security, performance, and feature updates.
278 questions
{count} votes

10 answers

Sort by: Most helpful
  1. MattMcSpirit-MSFT 561 Reputation points
    2021-01-26T20:20:33.483+00:00

    Hi all,

    @Trent Helms - MSFT - thanks for jumping in here. The guide that Michael is following is the one I wrote (and recently updated to reflect the slight changes to network deployment with WAC. It all runs in a nested config, and during node creation, MAC address spoofing is enabled: https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/steps/3b_AzSHCINodesPS.md#create-the-azshcinode01-vm-using-powershell

    As you rightly point out, there's a couple of quirks happening during this part of the wizard that we're investigating to understand if it's a 'nested thing' or if it happens in physical environments too.

    We're investigating, and we'll hopefully have fixes available in the near future.

    thanks!
    Matt

    1 person found this answer helpful.
    0 comments No comments

  2. keith 11 Reputation points
    2021-01-29T09:51:46.147+00:00

    Same issues. Only detail on the error

    61770-screen-shot-2021-01-29-at-14301-am.png

    And the error message only details:

    61842-screen-shot-2021-01-29-at-13019-am.png

    I do have a .har file from the Developer tools recording.

    I started the Eval in a Nested environment on a Window Server 2019 Standard. I did execute the additional PowerShell scripts that Matt posted as outlined: https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/steps/3b_AzSHCINodesPS.md#create-the-azshcinode01-vm-using-powershell

    Thanks for your work on this, pretty much followed everything down to the naming conventions etc.

    1 person found this answer helpful.
    0 comments No comments

  3. Gabriel Luiz 41 Reputation points MVP
    2021-01-31T03:24:17.787+00:00

    I also stopped at part 4, waiting for the bug to be fixed!

    1 person found this answer helpful.
    0 comments No comments

  4. Gabriel Luiz 41 Reputation points MVP
    2021-02-10T19:10:04.27+00:00

    Wonderful. I will test again. I am using nested virtualization to test Azure Stack HCI.

    1 person found this answer helpful.

  5. keith 11 Reputation points
    2021-02-11T07:32:48.71+00:00

    Yesterday - 2021-02-09, we downloaded the updated Clustering Extensions in WAC. We tore down the 2 HCI machines and redeployed them and was able to follow the Nested Eval Guide with no problems. Thanks for the update!!!

    1 person found this answer helpful.
    0 comments No comments