Unable to Configure Networking on Nested Setup

Michael Tughan 16 Reputation points
2021-01-19T20:13:42.35+00:00

I am attempting to set up Azure Stack HCI cluster for evaluation by following the guide at https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/README.md and https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/README.md. I have been able to proceed through parts 1-3 and have my management VM, my domain controller, and 2 nodes set up, but am getting stuck during part 4.

In part 4, creating the cluster (https://github.com/Azure/AzureStackHCI-EvalGuide/blob/main/nested/steps/4_AzSHCICluster.md), I can breeze through the Get started section; everything configures fine there. When I get to Networking, I am able to set up everything until the Define networks step. There, I have left Ethernet 2 alone, and set up Ethernet 3 to be Storage 1 on each node, and Ethernet 4 to be Storage 2 on each node. Regardless of how I set up the IP addresses (see below), I cannot get the cluster report to generate and proceed to the actual cluster creation.

After clicking Apply and Test, it applies changes to all network adapters, tests connectivity, attempts to create VSwitches for each interface (even though I selected to only create a VSwitch for the compute NICs in the steps previous, as described in the guide), and then attempts to test the cluster network. The first time I try it, I get an error after saying, "We couldn't configure and test network adapters. Please try again. Error: Failed to create a cluster network test report." If I just click Apply and Test again, it goes through the same steps as above, but hangs forever when testing the cluster network.

I have tried the following IP ranges, with node 1 being assigned device IP 1 (e.g., 10.10.10.1 for 10.10.10.0/24) and node 2 being assigned device IP 2:

  • Ethernet 2: APIPA (169.254.0.0/16 [it says 24 in the table in the guide, but this is incorrect; the 16 in the screenshot is correct]); Storage 1: 10.10.10.0/24; Storage 2: 10.10.11.0/24
  • Ethernet 2: APIPA (169.254.0.0/16); Storage 1: 192.168.10.0/24; Storage 2: 192.168.11.0/24
  • Ethernet 2: 192.168.8.0/24; Storage 1: 192.168.10.0/24; Storage 2: 192.168.11.0/24

I've tried ranges in 192.168.0.0/16 because my company also uses addresses in the 10.0.0.0/8 range and I wanted to make sure that it wasn't conflicting with the setup, but I get the same results.

I haven't been able to find anything about why the operations are failing, or what I can do to possibly resolve it. Can anyone help me out, either with some step-by-step guides or some pointers where I can even get some logs? Event Viewer doesn't have anything pertinent (only showing that it made a POST requests for a PowerShell command without logging the actual PowerShell run, as well as a telemetry call showing statuses being polled), and I haven't been able to find any logs on disk (checked C:\Program Files\Windows Admin Center as well as C:\ProgramData).

Azure Stack HCI
Azure Stack HCI
A hyperconverged infrastructure operating system delivered as an Azure service that provides security, performance, and feature updates.
295 questions
{count} votes

10 answers

Sort by: Most helpful
  1. MattMcSpirit-MSFT 561 Reputation points
    2021-01-29T17:16:40.04+00:00

    Thanks for this - I'm doing some testing with an updated cluster creation extension build in the next day or so, and all being well, it should fix these issues. I'll keep this thread up to date once I've done more testing.

    Thanks!
    Matt

    0 comments No comments

  2. keith 11 Reputation points
    2021-02-04T00:42:55.843+00:00

    Okay, I was able to get through the Network verification. What I did instead of connecting the Ethernet2, Storage 1 and Storage 2 NICs, I added them to the same subnet of 192.168.0.xx network addressing. I used 192.168.0.30 - 192.168.0.35 / 24.

    Everything succeeded after that.


  3. Gabriel Luiz 41 Reputation points MVP
    2021-02-04T02:22:31.313+00:00

    Hi ktf1234

    I'm leaving my contact gabrielluiz@Luxsparks .com, can we talk about how you solved this problem?

    0 comments No comments

  4. Mohammed Omar 1 Reputation point Microsoft Employee
    2021-02-10T19:06:06.463+00:00

    "Cluster Creation" extension has has been updated, and with last trial it worked smoothly for me, everyone should go to Windows Admin Center extension and update before creating the cluster.

    0 comments No comments

  5. Matt McSpirit 11 Reputation points MVP
    2021-02-11T15:38:37.513+00:00

    I can concur here - updating to the latest Cluster Creation Extension bits should fix any deployment issues that you're experiencing.

    Thanks!
    Matt

    0 comments No comments