Visio 2019 Standard - "Enable Live Dynamics" is greyed out

BBS-MW 6 Reputation points
2021-01-21T16:33:32.687+00:00

I have a user that all of a sudden found that the Live Dynamics was not working on his Visio 2019 Standard (build 16.0.13530.20376) - the latest version as of this morning's date I should note. One of his co-worker's hopped on Chat with Microsoft who basically suggested doing a re-installation of Visio . The user stated that his computer 2 days after this problem was occurring updated itself taking a couple of hours (it updated to 20H2). In a nutshell I've tried all of the steps below and none of them yielded a positive result. The only conclusion I can draw currently is that Visio requires something that is no longer present on the system and that part is refusing to activate. The PC meets the system requirements for Visio , so this must be some other lesser or non-published requirement possibly (or a bug in Visio perhaps)? - As the item is greyed out I'm leaning more to the first hypothesis rather than the latter.

Here's what I've done today:

  • verified the user was in the local administrator's group
  • signed on as a different user that had admin rights, which created a new profile on this computer - the problem still exists there --> note: this is with a fresh profile on this computer.
  • disabled hardware graphics accelleration - no change (re-enabled)
  • tried to do an online repair of visio - no change
  • turned on the setting to put all keys into the registry, then found the registry key for this function (see: https://admx.help/?Category=Office2013&Policy=visio15.Office.Microsoft.Policies.Windows::L_Enablelivedynamics) changed the value to 1 from zero and relaunched visio - no change, checked the registry (still a '1', closed visio - still a '1') - reopened, still disabled
  • Removed visio (then rebooted) and re-installed from the .img file it was originally installed from in 2019 (I believe the build showed as 1808 10730.20102) - no change
  • removed the graphics driver and reverted back to the basic driver - no change
  • ran windows updates to apply the latest driver for this device directly from microsoft (which back-dated the driver version a bit, that's good as I wanted to try a less current vidio driver to see if that helps) - no change
  • found a link (https://answers.microsoft.com/en-us/msoffice/forum/all/visio-pro-dynamic-grid-not-working/bc797b57-9fd1-4a49-98b9-e07d72cf8694?page=2) that mentions about going to the print window, page setup , page size tab and check "let visio expand the page as needed" - but that was already checked.

So to re-nutshell this - repairing / reinstalling , forcing the setting like group policy would (by registry key) - nothing makes the program comply with the instruction to enable that function. I've looked around to see what the pre-requisites for that function are but it doesn't appear to be published.

Anybody from Microsoft have any ideas why this function in your software refuses to activate even when the registry setting is turned on for this (and all of the steps above having been done) ?

Thanks

Visio Management
Visio Management
Visio: A family of Microsoft products used to create diagrams and vector graphics.Management: The act or process of organizing, handling, directing or controlling something.
249 questions
0 comments No comments
{count} vote

6 answers

Sort by: Most helpful
  1. Holmes, Quentin 0 Reputation points
    2023-01-11T23:08:44.3733333+00:00

    I have this exact same issue. I have had it for years. After a Visio update any shape i dragged around was just a box which is not fun when some of them are complex. We are not using flow chart symbols. I gave up trying to figure it out on my desktop. It worked fine on my Laptop. I just received a new desktop and guess what. The same issue again. Its seems impossible. Now i did check and my laptop is Visio 2013, my old desktop is Visio 2016 and my new desktop is Visio 2019. I have a colleague who uses 2016 and his is fine. Also a laptop. I tried changing the reg key from above and it did nothing. Has anyone made any progress on this at all?

    I was wondering in my case if it was how the install was done. In the past i have found that Visio specifically had issues with how add ons were installed. Via an IT person remote with separate admin log in vs giving temp local admin privileges. The temp local privileges worked every time. All my software is loaded automatically or via IT remote access.

    I would love to find an answer for this.

    Thanks

    Q

    0 comments No comments