Azure time function not firing

BMO 21 Reputation points
2021-01-30T12:49:57.527+00:00

As the title says, my time function does not trigger when I upload it to the cloud. I created a test function that triggers every minute and saves the time in a SQL table. When I run it locally through VS, it works but when I publish it, it does not trigger.

I already deleted the function app and created a new one but it still doesn't work. In the Azure Portal, the function is enabled. I've seen some people talking about the App Service Plan. I have a student service plan and can't find the option "Always On" as everyone talks about.

Does anyone have any idea of what it could possibly be?

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,352 questions
0 comments No comments
{count} votes

Accepted answer
  1. MayankBargali-MSFT 69,411 Reputation points
    2021-02-01T12:07:13.677+00:00

    Hi @BMO

    Welcome to Microsoft Q&A! Thanks for posting the question.

    Can you navigate your function --> Under Developer (Monitor) --> Invocations and verify if you see any invocation history for your function?

    Want to make sure that the function was triggered or not? If triggered then was there any errors?

    62522-image.png

    Also verify whether you have AzureWebJobsStorage key added in your configuration of application settings. If it is not there please add the Name as AzureWebJobsStorage and value as your storage account connection string.

    62581-image.png

    <SNIP>
    The Azure Functions runtime uses this storage account connection string for normal operation. Some uses of this storage account include key management, timer trigger management, and Event Hubs checkpoints. The storage account must be a general-purpose one that supports blobs, queues, and tables. See Storage account and Storage account requirements.
    </SNIP>

    Reference: https://learn.microsoft.com/en-us/azure/azure-functions/functions-app-settings#azurewebjobsstorage

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful