Extreme lag on Microsoft Remote Desktop Mac client

Elmar Jense 61 Reputation points

I experience extreme lag in all my actions on the MacOS Remote Desktop Client, where every mouse click takes up to 30 seconds to take effect.
my setup is the following;

MacBook Pro 15" (2015)
External USB-C 4K monitor (lg)

This problem only occurs when the external monitor is connected. If I only use my Macbook, there is no lag at all.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,146 questions
{count} votes

12 answers

Sort by: Most helpful
  1. Özberk Akbaş 26 Reputation points

    Hello I have been trough the same issue and this might come late.

    The connection I have tested this solution is Mac (client) -> Windows (host)

    I went to the connection settings and disabled the "Hardware acceleration" and everything is just fine now. I think it is something with the M1 chip.


    Hope it helps

    5 people found this answer helpful.

  2. Roelan 16 Reputation points

    I think the problem is the external mouse, not the external screen.
    And only when using the gateway.

    When I use the touchpad it works fine. I don't even have to unplug the external mouse. Very strange.

    EEDIT: I now tried an old microsoft mouse (also usb) and that works fine. The Ducky secret M doesn't.

    3 people found this answer helpful.
    0 comments No comments

  3. CptLeergut 11 Reputation points

    EDIT: Please see UPDATE 2 below.

    I have the same problem @Karlie Weng .

    When I try to connect via RDP to my company's network (using an RDP gateway), it becomes unusable as soon as I connect an external display to a brand-new MacBook Air. Disconnecting the external display renders RDP fine again. So it works correctly only if just the integrated display is used. I also tried Microsoft Remote Desktop Beta (10.6.2, 1874) without success.

    However, I can connect to a local Windows PC just fine even with an external display (no RDP gateway in-between).

    3rd-party clients like Jump Desktop or Royal TS do not cause such problems. Also, connecting to my company's network via RDP on a Windows PC works as expected.

    UPDATE 1 (2020-04-19): I use an external LG 4K monitor. I have tested it with a Sony 4K TV now (actually with an AVR that is connected to the TV) and it works fine. So it seems to be related to the actual monitor somehow?

    UPDATE 2 (2020-04-20): I am using a USB-C hub through which I connect my mouse, keyboard and display. I have found out now, that the issue occurs only when the mouse (Logitech G402) is plugged-in. It doesn't even matter if there is another external monitor connected. Even by unplugging everything else from the hub (i.e. only connect the mouse; no keyboard or display), it does not work. I tried with another mouse and it works as expected. Is it possible that the RD gateway somehow dislikes the mouse? Or the polling rate or something like that? I also tried to connect the mouse directly to the USB-C port with another adapter, and it does not work correctly in RDP. So it's not the hub's fault.

    @Elmar Jense @Michel, T Do you use a similar setup? Maybe this helps.

    2 people found this answer helpful.

  4. Chris Smith 15 Reputation points
    1. The easiest work around is to uninstall the version from the App Store (or any versions you have) and manually install the older v10.7.3 which runs good: https://install.appcenter.ms/orgs/rdmacios-k2vy/apps/microsoft-remote-desktop-for-mac/distribution_groups/all-users-of-microsoft-remote-desktop-for-mac. Also turn off auto updates within the app/just ignore any new releases until there is a fix for this issue.
    2. The other work around is to install Parallels Desktop and setup a windows VM and then just use the native remote desktop client within Windows. This was my previous workaround before I realized v10.7.3 was functional.
    3. Others that have talked about mouse polling being the issue may be right. I have a Razer Abyssus v2 mouse with high polling rate so maybe if I used a less fancy/basic mouse maybe that will fix it as others have said.

    FYI I haven't seen anything too compelling in the newer versions > v10.7.3 so I don't think we're missing out on "new stuff".

    There is one bug I have seen in v10.7.3 though: multiple monitors (in my case 3 monitors) can be fussy where the Spaces get mixed up between MacOS and the rdp session but only affects the non-primary monitor(s). For example, I will remote into my work computer (Windows) and my right monitor stays on MacOS and my primary goes to the rdp session/Windows. Then when switching Spaces (CTRL+right arrow or CTLR+left arrow), the primary monitor goes to MacOS and the right monitor goes to my rdp session (so they are inverted). The workaround for this is to go to System Preferences > Displays > Display Settings... (lower left) > keep this Display Setting pref window open > switch back to MS rdp app and disconnect and reconnect your session (or quit and re-open MS rdp app and reconnect). This bug is annoying but better than RDP basically being unusable in the newer versions.

    I have been complaining about it for about a year but hopefully it will get addressed this year.

    2 people found this answer helpful.

  5. Richard in Pasadena 15 Reputation points

    For me, this issue occurs on a Mac mini with 2 LG 4K monitors connected, and the computer I remote into is a windows computer, which also has 2 LG 4K monitors.

    My connection starts fast at first, but after a few minutes of use, there is more and more lag. Eventually, the lag would become unbearable and I kept having to turn off RDP, then reestablish the connection to reduce the lag. But the solution below completely fixed the issue.

    HERE IS THE FIX: Go to the "Settings" menu in Microsoft Remote Desktop. On General Screen Tab, uncheck "Use hardware acceleration when possible" AND also set "Graphics Interpolation Level" from "Automatic" to "High." This completely fixed the issue.

    2 people found this answer helpful.