Why can't I start a stateful service in azure service fabric cluster?

Nsutgio 1 Reputation point
2019-12-10T06:29:38.683+00:00

Hi,

I'm new to service fabric cluster, and I have a problem with stateful services. I tried creating a single node cluster in azure, and first tried to deploy a stateless service, and it just worked fine. But, when I tried a stateful service, it always gives an error. I'm using a Free Trial subscription, is there something to do with it? Or, if not, is there another way of setting it up, that I can run a stateful service in azure with a Free subscription?

Please someone help. Thanks in advance.

Azure Service Fabric
Azure Service Fabric
An Azure service that is used to develop microservices and orchestrate containers on Windows and Linux.
253 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. vipullag-MSFT 25,366 Reputation points
    2019-12-10T06:54:15.747+00:00

    @Nsutgio
    Free Trail Subscriptions has noting to do with this issue.

    Stateful service runs on multiple replicas (by default 3 partitions) to take care of data failures.
    As you are running a single node cluster you are seeing issues. To avoid data loss, it is recommended to run stateful service on more nodes.
    Please check this FAQ document for mode information.

    In ApplicationManifest.xml you can set the Replica count Default value to 1 (by default it is 3, but this is not recommended for stateful service).

    1 person found this answer helpful.
    0 comments No comments