Hello @Brandon Melton ,
I did an internal research on the error message you provided and below is the RCA which I found:
Issue:
Issue connecting through Azure VPN Client on some machines but works for others.
Error code: Failure in acquiring AAD Token: Provider Error 2147942756
Cause:
The issue occurs when deployment is completed with Intune and the error in Azure VPN log (Error 2147942756) comes back as Windows Information Protection Policy.
Resolution:
Confirm that you are using the recommended configuration for the VPN policy following the article below and if everything is correctly configured please try to set a new policy for test users to discard any problem with the policy. This worked in several previous cases related to WIP:
https://learn.microsoft.com/en-us/windows/security/information-protection/windows-information-protection/create-vpn-and-wip-policy-using-intune-azure
Hope this helps!
Kindly let us know if the above helps or you need further assistance on this issue.
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