Outlook keeps disabling the Teams Plug-in

Steve R 26 Reputation points
2021-02-26T16:07:40.037+00:00

Been using Office 365 for about a year now and Outlook's favorite dirty trick is to declare the Teams plug in unworthy and disable it when Outlook loads. Makes it a real PITA to schedule a Teams meeting. I'm open to suggestions. Thanks!

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,583 questions
0 comments No comments
{count} votes

8 answers

Sort by: Most helpful
  1. JimmyYang-MSFT 50,446 Reputation points Microsoft Vendor
    2021-03-01T08:57:21.66+00:00

    Hi @Steve R
    Could you find the Teams meeting Add-in in Outlook Com Add-ins?
    72981-2.png

    If the add-in still does not show, use the following steps to verify the registry settings.

    1. Launch RegEdit.exe
    2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins
    3. Verify TeamsAddin.FastConnect exists.
    4. Within TeamsAddin.FastConnect, verify LoadBehavior exists and is set to 3.
    5. If LoadBehavior has a value other than 3, change it to 3 and restart Outlook.
      For more details about how to troubleshoot this issue, you can refer to:
      https://learn.microsoft.com/en-us/microsoftteams/teams-add-in-for-outlook#troubleshooting

    If the add-in has been disabled, you can try to follow these steps to prevent it:

    1. Open Run, type “regedit” to open the registry editor.
    2. Go to “HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Resiliency” (16.0 for Outlook 2016)
    3. Delete the DisabledItem if there is.

    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    13 people found this answer helpful.

  2. Micah Amstutz 41 Reputation points
    2022-04-28T20:41:18.067+00:00

    I had a user running into this issue. I tried all the recommended fixes and they would either not work, or would only temporarily work (less than a day). In Outlook, I discovered that it was listed in "Slow and Disabled COM Add-ins" found in File > Info. The average delay in my case was 0.66 seconds. I set it to always enable this add-in and that fixed the issue for me. Hopefully this helps someone else. It took me quite some time to find it.

    7 people found this answer helpful.

  3. PauloKinopk 56 Reputation points
    2021-05-27T17:15:39+00:00

    I had the same issue with a user today.

    These steps worked for me:

    1. Close Outlook and Teams
    2. Uninstall Microsoft Teams and Teams Machine-Wide Installer
    3. Under %localappdata%\Microsoft delete the folders: SquirrelTemp, Teams, TeamsMeetingAddin and TeamsPresenceAddin
    4. Download and re-install Microsoft Teams
    6 people found this answer helpful.

  4. Uli 11 Reputation points
    2022-05-20T08:48:00.953+00:00

    I'm seeing multiple users with this issue - we are finding the fixes above aren't permanent. Does anyone know if there is a way to set the "always enable this add-in" perm when deploying the add-in via Intune? We're hoping to make this a non-issue for our users.

    2 people found this answer helpful.

  5. Sahil Aggarwal 1 Reputation point
    2021-05-03T10:46:34.413+00:00

    You may also want to check the "Slow and Disabled Add-in" in the File menu and take corrective action (by stop monitoring).
    In my case, Teams add-in slowed Outlook hence it was disabled.