How to fix Microsoft.ACE.OLEDB.12.0 provider is not registered on the local machine

Rhys Mckinnon 31 Reputation points
2021-03-03T03:33:06.02+00:00

After trying to follow several solutions online none seem to be working. I'm using 64bit Microsoft access and 2019 visual studio and have already installed the engine from https://www.microsoft.com/en-au/download/details.aspx?id=13255. I've tried running visual studio on x86 and any cpu. Stumped on where to go next

.NET
.NET
Microsoft Technologies based on the .NET software framework.
3,538 questions
{count} votes

8 answers

Sort by: Most helpful
  1. Ashwini Kumar Vijayvargia 5 Reputation points
    2023-04-19T03:32:35.0766667+00:00

    I was facing the similar problem, in one project, while in other project running on the same machine working fine with the same connection string. Changing 'Target CPU', didn't work. But I removed the check 'Prefer 32 Bit' just below this 'Target CPU' option, and it worked. I'm using VS2022 Community Edition.

    1 person found this answer helpful.

  2. Max Santeramo 21 Reputation points
    2022-06-02T15:16:55.177+00:00

    I run into the same problem but nothing seems to work. I run windows 10 and Visual Studio 2022. All is 32bits including office but no matter what I always get hte bloody OLED12 service provider not registered issue. I also tried the previous solution but there's no way, it doesn't work. Also if I try to install the 64 bit version of AccessDatabaseEngine is raises an error due to the different bitness. What can I do? Thanks for your support.


  3. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more