Can't get into Teams

Craig Stevens 11 Reputation points
2021-03-16T23:53:48.787+00:00

Hi, I posted this yesterday on Microsoft Answers but they told me to post it here, so here goes......

I'm a Linux Mint user with the Teams app installed. I used to use Windows back in 2009 so I have a Live ID that I use for Skype and anything else that occasionally needs it. I do not have a paid Office account.

A couple of years ago I had a contract to work for an organisation that was fully Office 365'd so I used to log into their Teams using an email address they gave me. Once I left, that email address was then deleted.

Now, over a year later, a new client sent me a Teams meeting request. Now I find I can't log in to Teams at all, either via a browser or the Microsoft Teams for Linux app. It all seems to be due to the LiveID authentication system.

At first I enter my only email address then I'm asked whether to use Work or Personal account. (I only have ONE email address remember), if I choose "Personal" I then enter my password and wait. Then I see "Someone has already set up Teams for your organisation". Well they (I) haven't. So if I then select "Use a different Email" a web page opens showing me as logged in to Microsoft.com. If I log out and click "Sign up for free" it say's I'm already logged in and if I then continue I'm back in the app where "Someone has already set up Teams for your organisation".

If I sign out of the app and sign back in again and this time select Work and enter my password and wait for ages I then get "You're missing out! Ask your admin to enable Microsoft Teams for xxx@X .net"

There is one scenario which I can't recreate to order right now where when I try to log in, I get sent to my old Client's Teams page with their branding on and a big white box saying my OLD email address doesn't exist in their tenant. I mean, I don't want to use their system and I'm not even trying to log in with that old email address.

I've tried clearing cookies, uninstalling, purging and reinstalling apps, going to myaccount.microsoft.com and signing out of everything and waiting a couple of hours. There's just no way on earth I can log in and no easy way of communicating with MS hence this post.

I'm guessing there's something somewhere linking all this stuff together in the background and it's totally screwed AND there's no way the user (i.e. me as the admin) can get access to sort it out.

Any advice would be greatly appreciated.

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
456 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Craig Stevens 11 Reputation points
    2021-03-17T13:53:17.933+00:00

    Hi Thanks. I already read that and many other articles but they don't address my issue unfortunately.

    It appears LiveID has somehow decided my single email address is associated with multiple accounts. How do I straighten it out? I have ONE email address which I'm not going to change. There must be some way of fixing the account associations.

    I find the LiveID system was originally a good idea but after a few years, as MS systems evolved and they bought other systems and tried to patch it all into LiveID it has become an unholy mess, which is what I think has caused this issue. It's never clear which path to go down and since they bought Skype, that caused great issues when people you could talk to using you SkypeID ended up on Skype for Business for which you needed to log into Microsoft with your LiveID. As they both had my email address I'm guessing that's where MS have totally inappropriately linked stuff together. As for linking my email address to an account which I accessed on an email address provided by an old client (I'm a freelance web dev), that should never have happened.

    Any practical advice would be appreciated.

    1 person found this answer helpful.

  2. Sharon Zhao-MSFT 25,081 Reputation points Microsoft Vendor
    2021-03-17T02:26:55.093+00:00

    @Craig Stevens ,

    "Someone has already set up Teams for your organization"

    About this error message, there are multiple possible causes and resolutions. You could refer to the following resolutions:

    Cause 1. Someone has already set up Teams for you.

    Resolution 1. Look for an invitation in your email Inbox. Alternatively, try to sign in to Teams from a private or incognito browser window.

    Cause 2. Your email address is tied to both a work and a personal account.

    Resolution 2. Try to create a Teams account in a new private or incognito browser window. If that doesn't work, you must unlink the two accounts to create a free Teams account. For more information, see Change the email address or phone number for your Microsoft account.

    Cause 3. You’re trying to sign up for your work account by using a free tenant.

    Resolution 3. Use your organization’s tenant for this account.
    For more details, please refer to this article.


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments