Windows 10 Updates - KB2267602 Security Intelligence update Fails to Install

Stan Kasper 1,266 Reputation points

Today I took a generic Windows 10 20H2 machine and decided to update it with the 'keep nothing' option. After the initial install I set the proper time and did a WIndows Update. The update installs but hangs up on KB2267602 and gives me the error 0x80070643.

I am doing a fresh install and 20H2 bombs. Very sad.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
6,662 questions
{count} votes

9 answers

Sort by: Most helpful
  1. Barış S 51 Reputation points

    I had the same problem 10 minutes ago. Simply clicked "Pause updates for 7 days" and then "Resume updates". It reinstalled the same update correctly. I don't know if it would solve your problem but it's worth a shot.

    10 people found this answer helpful.

  2. Manuel Monteiro 6 Reputation points

    i am having the same problem....
    the way to fix it is running twice the troubleshooter.
    i resolve 2 errors like that.


    1 person found this answer helpful.

  3. S.Sengupta 5,871 Reputation points MVP

    Open an elevated command prompt windows, type the following commands one after the other, and hit Enter:

    net stop wuauserv
    net stop bits
    rename c:\windows\SoftwareDistribution SoftwareDistribution.bak
    net start wuauserv
    net start bits

    Open an elevated Command Prompt, type the following command one after the other and hit Enter:

    net stop cryptsvc
    md %systemroot%\system32\catroot2.bak
    xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.bak /s

    Move to C:\Windows\System32\catroot2.
    Then, Delete everything from this folder.

    Now, Run the following command.
    net start cryptsvc

    Then, Check for the latest Windows update.

    See also:

    Windows Update Troubleshooter for Windows 10

  4. Stan Kasper 1,266 Reputation points

    Wow. I tried the troubleshooter. Did not fix the issue. I tried to rebuild the update catalog. Ran into permissions issues even when admin and didnt want to play around with that. Besides all those steps would make one certifiable.

    Keep in mind this is a reinstall from the latest Windows 10 20H2 ISO where I tried 'keep nothing' and I also booted and deleted the existing disk partitions.

    One possible fix is that now the WIndows updates are 'asynchronous' but you need to wait. You get the silly 'restart' button but Windows Updates are still downloading and installing. So I waited for everything to finish before a restart. I did this before. But for some reason when I did it now it worked. There seems to be some dependencies with KB2267602 and others in the install order. Maybe MS addressed this today?

    It is rather disheartening that on a fresh reinstall this type of issue would come up. Right now I am leaning towards the problem being an install timing / dependency issue. As such all of the above suggestions are of less help as this is appears to be a Microsoft issue.

    Here is what the list of updates for Win10 20H2 look like on a clean reinstall:

  5. Teemo Tang 11,051 Reputation points

    Since this is a recent fresh install computer, you could install the latest SSU and the latest CU, after this, your computer has been up to date.
    About Microsoft Defender update, we usually don’t need to care, Windows Defender will update itself with Windows Update. Or you could manually install update for it from here:


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.