User's unable to create folders in Public Folders after migration from SBS2011 to Exchange 2019

Nimal Sirimanne 1 Reputation point
2021-05-02T23:00:37.057+00:00

Hi everyone, would appreciate some Exchange expertise and advice into a weird problem we are facing post migration.

We recently migrated users from SBS2011 to Exchange 2019. Everything is working except when users try to create subfolders within Public Folders. The error is 93203-pf-permissions.jpg

There is no error or issue if we try to move an email into the Public folders or any of the subfolders.

We also noticed that sometimes when we try to browse into the Public folder, we would be greeted with another error:

93204-pf-permissions-1.jpg

  • First thing we checked was permissions - users had "Owner" rights to the public folders. We tried removing and re-adding the permissions via GUI and Powershell but that made no difference
  • Made sure that users were using latest version of Outlook, which they were.
  • Created new Outlook profile, but made no difference.
  • We created a new user, granted the user "Owner" rights and tried to create subfolders - but same issue. However, we did notice that sometimes the subfolder would be created, even if we received an error.
  • Followed steps listed in Can't expand or add public folders in Outlook or OWA but was not relevant.
  • Followed steps listed in How to diagnose and fix public folder permission issues , but at step 2c, there was no error, and all commands worked, showing that the user had Owner rights.

If anyone has any idea what is going on or how we can isolate the problem, that would be great. Some information about the PF and structure below:

93211-pf-permissions-3.jpg
93212-pf-permissions-5.jpg

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,230 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. KyleXu-MSFT 26,201 Reputation points
    2021-05-03T06:42:43.947+00:00

    @Nimal Sirimanne

    How do you migrate public folder from Exchange 2010 in SBS 2011 to Exchange 2019? Exchange 2019 cannot coexist with Exchange 2010, it only suggested migrate public folder from Exchange 2013/2016 to Exchange 2019.

    I think this issue may related with the way that used to migrate public folder.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Nimal Sirimanne 1 Reputation point
    2021-05-03T22:34:56.207+00:00

    Hi KyleXu,

    We migrated everything including PF from SBS 2011 to Exchange 2016, then from Exchange 2016 to Exchange 2019.

    SBS2011 and Exchange 2016 servers have been shutdown and removed from network, so only the Exchange 2019 is live.

    Do let me know if you need any further information.


  3. Nimal Sirimanne 1 Reputation point
    2021-05-11T01:32:26.017+00:00

    Hi Kyle - this was the first thing i tried :) Did this using powershell as well, but no change in user experience.