AADDS/DNS - Company website not getting resolved

Sandeep Kumar 21 Reputation points
2021-05-12T06:21:49.813+00:00

I have AADDS in azure with the name xyz.com with private IP 10.0.0.4 & 10.0.0.5. DNS Name is xyz.com... Now when am creating VM in azure and adding it to xyz.com domain and dns for the same on v-net are 10.0.0.5 and 10.0.0.4. VM is working fine, am login with Azure AD user and the Internet is also working but when am trying to open the company website https:\xyz.com it only resolves 10.0.0.4 and 10.0.0.5 (As DNS name is xyz.com) what should I do so that when I open https:\xyz.com it should go to actually public IP where website is hosted.

Microsoft Entra
{count} votes

2 answers

Sort by: Most helpful
  1. Siva-kumar-selvaraj 15,571 Reputation points
    2021-05-18T11:00:31.94+00:00

    Hello @Sandeep Kumar ,

    Thanks for reaching out and sorry for delayed response.

    This would create DNS name conflicts for the domain name on the virtual network. A DNS lookup checks if an existing domain name conflict. To resolve this conflict scenario, use a different name to set up your managed domain, or use different company name for website.

    https://learn.microsoft.com/en-us/azure/active-directory-domain-services/troubleshoot#domain-name-conflict

    Hope this helps.

    ------
    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    0 comments No comments

  2. Andrew Woods 76 Reputation points
    2021-06-27T08:51:07.327+00:00

    Hello SandeepKumar-3473

    This will be happening as the dns service in aadds doesn’t know about your public site, you can create an a record for example www.xyz.com pointing at the public IP address to resolve this.

    Hope this helps

    Kind regards
    Andy

    0 comments No comments