Unable to Copy and Paste to and from remote desktop connection on some servers.

Akshay 1 Reputation point
2021-05-21T12:48:56.863+00:00

Unable to Copy and Paste to and from the remote desktop connections on some servers. None of the file types are working. I tried folder copy, text file copy, word, excel, .exe file copy. none of those work. Interestingly, copy-paste of text to and from works.

Client OS is Windows 10.
Remote Desktop Server OS is Windows server 2016.

Troubleshooting did so far:

  1. Killed rdpclip.exe and tested. No luck
  2. Rebooted the server and the client. No luck
  3. Added rdpclip.exe to exclusions in Antivirus. No luck
  4. Removed Antivirus and tested. No luck.
  5. Tried local login to the remote desktop server instead of domain login. No luck
  6. Verified in the group policy and made sure Do not allow Clipboard redirection and
    Do not allow drive redirection are set to not configured.
  7. Replaced the rdpclip.exe from a working server. No luck.
  8. Compared local security policies (secpol.msc) with a working server and replicated the same settings on the non-working server. Rebooted after that. No luck.
  9. Tried disabling all the Group Policies that are pushed through Domain Controller. No luck.

Any suggestions as to what more we can do to identify and fix the issue?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,383 questions
{count} votes

10 answers

Sort by: Most helpful
  1. Anonymous
    2021-05-24T05:20:45.66+00:00

    Hi, dear It's highly recommended you use Drive Redirection through Remote Desktop Services if you want to transfer files. Firstly, run command with Mstsc.exe. When the Remote Desktop Connection window appears, click the Show Options button at the bottom left of the window. On the Local Resources tab of Remote Desktop Connection, you can specify which kinds of devices and resources that they want to redirect to the remote computer. Now that drives on the local computer can be redirected in the session so that files can easily be transferred between the local computer and the remote computer. ![98945-image.png][1] In the meanwhile, you can edit client drive redirection by configuring a Microsoft Remote Desktop Services group policy setting for remote desktops and RDS hosts. Run command with gpedit.msc. In the Group Policy Editor, go to Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection. Secondly, you should check the rdpclip.exe on your remote computer with Task Manager to see if it is processing well. Cause Remote Desktop Clipboard is a Windows utility that allows users to manage a shared clipboard between a local host and remote desktop. This application runs on the remote PC and not on your local host. Run command with taskmgr.exe - Go to the Processes Tab - Select rdpclip.exe - Click End task ![98867-image.png][2] Go to the File tab - Click Run new task - Type rdpclip.exe - Click Ok ![98964-image.png][3] ![98965-image.png][4] If the Answer is helpful, please click "Accept Answer" and upvote it. Best Regards [1]: /api/attachments/98945-image.png?platform=QnA [2]: /api/attachments/98867-image.png?platform=QnA [3]: /api/attachments/98964-image.png?platform=QnA [4]: /api/attachments/98965-image.png?platform=QnA

    6 people found this answer helpful.

  2. Anonymous
    2021-06-02T13:31:27.647+00:00

    Hi,

    Haven't received your message in a few days, was your issue resolved?

    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as an answer which can help other community members who have the same questions and find the helpful reply quickly.

    Best Regards.

    0 comments No comments

  3. BrianW 1 Reputation point
    2021-11-18T20:22:27.49+00:00

    Same problem, Windows 10 client and server is Windows 2019. None of the client or server side methods above solve the problem to reset it.

    What causes it to stop working is when I copy a large amount of text across the RDP connection, ie 500-1000+ rows (exact number not yet determined). The clipboard stills functions on client/server independently but no longer across the connection.

    0 comments No comments

  4. 64193216 1 Reputation point
    2021-12-13T02:57:32.857+00:00

    Anyone got a resolution to this?

    I've got the exact same problem as Akshay, tried the same things to no avail.
    Can even copy text to / from the server but no files.

    For reference this issue is only happening on my session hosts - other RDS server that has connection broker / session host on it doesn't have this issue.
    Issue persists when connecting to the problem session host via connection broker and directly with 'mstsc.exe /admin'.

    Further investigation appreciated anonymous user


  5. rsn71 1 Reputation point
    2022-02-11T16:44:17.803+00:00

    I am having this issue and have tried everything in this post - the RDC already had Clipboard checked. I have rebooted the server, the laptop that I am using RDP on. Still unable to copy and p paste from the Event Viewer. I can't even copy and paste to Notepad on the same server with NO RDP.

    This is ridiculous - with a Mac you can copy and past from any dialog box that pops up. Why on earth desert Microsoft allow this on all their products and OS? Makes life so much easier and saves a ton of time for the administrator.

    Microsoft needs to think about how their customer use the event viewer log.

    0 comments No comments