Hi @isabelle stortz ,
Thanks for your question! The error you mentioned is documented in the No subscriptions found troubleshooting guide:
Cause
This problem occurs if you selected at the wrong directory, or if your account doesn’t have sufficient permissions.
Solution
Scenario: Error message is received in the Azure portal
To fix this issue:
Make sure that the correct Azure directory is selected by clicking your account at the top right.
If the right Azure directory is selected but you still receive the error message, assign the Owner role to your account.
If it's still defaulting to a different account you may need to try this in a fresh browser in an incognito window.
I am not sure exactly what account you wish to remove from where, but you may find these articles helpful:
To close your Microsoft account entirely: https://support.microsoft.com/en-us/account-billing/how-to-close-your-microsoft-account-90ae1e6c-632d-ad40-5e5e-3c0d7d6d8774
To leave an Azure organization: https://learn.microsoft.com/en-us/azure/active-directory/external-identities/leave-the-organization
To remove a device from a company: https://learn.microsoft.com/en-us/mem/intune/user-help/remove-your-device-cpwebsite
What software is it that keeps reinstalling? And from where are you trying to remove the account?
Please note that Q&A is only available in English at this point, but we will try our best to answer all inquiries.