Sharing screen not working anymore [BUG]

Giovannetti, Antonio 116 Reputation points

since I have installed MS Teams latest version (, sharing screen is not working anymore. I had to downgrade to version and then sharing screen is restored.

Thanks for support

Skype for Business Linux
Skype for Business Linux
Skype for Business: A Microsoft communications service that provides communications capabilities across presence, instant messaging, audio/video calling, and an online meeting experience that includes audio, video, and web conferencing.Linux: A family of open-source Unix-like operating systems.
456 questions
{count} votes

Accepted answer
  1. Marian Javorka - MSFT 936 Reputation points Microsoft Employee

    @GiovannettiAntonio-4409 thank you for raising this feedback. Do you perhaps have i3 WM? In we introduced screensharing red border indicator and we noticed that on i3 it causes issues with transparency.

    Symptoms would be black screen with red border. If you do have this, can you try to rename this file (so it is not used)
    and try again?

    We are working on the fix on our side.

    30 people found this answer helpful.

11 additional answers

Sort by: Most helpful
  1. Jose Alonso 16 Reputation points
    3 people found this answer helpful.
    0 comments No comments

  2. Michael 21 Reputation points

    Just want to add some additional details, because I have two systems with different hardware but the same software (window-manager, DE, ...) and not using i3 as a WM. On one screen sharing works, on the other it is broken (black screen, with red border).

    I tried to run 'rect-overlay' directly via rect-overlay -p 0x0 -s 100x100 and on the notebook it works fine, and on the desktop machine I get a black screen with a 100x100 red bordered rectangle.

    On both systems I currently run an up-to-date Debian Unstable with KDE/Plasma with a X-server and the package is retrieved via apt: 'deb [trusted=yes] stable main'
    me debian version and 'similar' packages installed, where screensharing/overlay-rect is working (Lenovo X1 Carbon 2nd gen: Intel CPU, Intel graphics, X-Server, KDE/Plasma).

    Summary of the setup where screensharing stopped working:

    • Hardware
    • CPU: AMD Ryzen Threadripper 1920X 12-Core Processor
    • Mainboard: MSI X399 Gaming Pro Carbon AC
    • Graphics-Card: MSI Radeon RX 560 Aero ITX OC 4GB
    • Single monitor setup (1920x1200)
    • Sofware versions
    • QT-Version: 5.14.2
    • KDE Plasma: 5.17.5
    • X-Server: 7.7
    • Kernel: 5.7.6
    • GPU-Module: amdgpu 19.1.0 (open-source version)

    In contrast the Notebook where screen sharing is working:

    • Hardware
    • CPU: Intel(R) Core(TM) i7-3667U
    • GPU: Integrated Graphics: Intel HD 4000
    • Lenovo Thinkpad X1 Carbon 2nd Gen (2012)
    • Notebook monitor only (1600x900)
    • Software versions
    • SW-Versions are the same as on the system with the bug, except the graphics module
    • GPU-Module: i915/intel 2.99.917

    Feel free to reach out for further information

    1 person found this answer helpful.
    0 comments No comments

  3. Michael 21 Reputation points

    Found the difference on my two systems: on the working system the compositing was active and on the not working machine the compositing was switched off.
    Switching compositing on on my desktop machines allows 'rect-overlay' to work properly.

    1 person found this answer helpful.
    0 comments No comments

  4. JLC 11 Reputation points

    You've nailed it. Some weeks ago I decided to comment this line out in my ~/GNUStep/Library/Windowmaker/autostart:

    compton -r 12 -o 0.75 -l -15 -t -15 -i .87 -I 0.028 -O 0.03 -D 3 -c -f -C -G -b

    to not interfere with the settings of the remote machine I access via VNC to do my teleworking. That line calls the external composer "compton". After uncommenting the line and renaming back to "rect-overlay" sharing works properly again. Well, not so properly, because I need also to eliminate the option "-c" in the compton invocation, that enables a black shadow on client windows at the right and bottom sides (option "-r" indicates the blur radius for shadows, and option "-o" the opacity of shadows). With the "-c" and "-o 75" options enabled, all the area inside the red rectangle (the shared area) gets shadowed with an opacity of 75%...

    To suppose all Linux people use a composer it's perhaps a bit too much, imho... Most users of bare window managers (fvwm, i3, Window Maker, fluxbox, blackbox, iceWM, JWM, awesome, you name it...) don't need it and don't use it.

    1 person found this answer helpful.
    0 comments No comments