RDP - do not allow new connections broke my server

Siraj Patel 96 Reputation points
2021-06-20T20:42:06.967+00:00

Hi guys,

I am lost :(

I enabled 'do not allow new connections' in our RDP server as I did some updates.

107367-image-2021-06-20-213834.png

Rebooted the server.

Went back in via Hyper-V, turned it off to allow new connections, and now I can't RDP from any machine to the server? Its as if its still set to 'do not allow new connections'

107325-rdp.png

I am totally lost. What can I do and try?

:(

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,294 questions
0 comments No comments
{count} votes

Accepted answer
  1. Siraj Patel 96 Reputation points
    2021-06-20T23:26:28.287+00:00

    @Andreas Baumgarten

    I've got to the bottom of it. I can't believe this but, it was my antivirus. The dam thing updated and decided to change the soft firewall. I decided to uninstall it just for testing, and I got straight in.

    I just want to say, thank you for your attempted help.

    0 comments No comments

7 additional answers

Sort by: Most helpful
  1. Andreas Baumgarten 98,626 Reputation points MVP
    2021-06-20T20:56:18.533+00:00

    Hi @Siraj Patel ,

    you could try to get this fixed via PowerShell (just replace the SessionHost and ConnectionBroker values):

    Import-Module RemoteDesktop  
    Set-RDSessionHost -SessionHost "rdsh.contoso.com" -NewConnectionAllowed Yes -ConnectionBroker "rdcb.contoso.com"  
    

    Source: https://learn.microsoft.com/en-us/powershell/module/remotedesktop/set-rdsessionhost?view=windowsserver2016-ps

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments

  2. Siraj Patel 96 Reputation points
    2021-06-20T21:04:24.597+00:00

    @Andreas Baumgarten

    Apologies but a question.

    The users access the RDP from a local LAN via an IP.

    Would this be correct:

    Set-RDSessionHost -SessionHost "192.168.1.4" -NewConnectionAllowed Yes -ConnectionBroker "192.168.1.4"

    0 comments No comments

  3. Andreas Baumgarten 98,626 Reputation points MVP
    2021-06-20T21:10:49.22+00:00

    Hi @Siraj Patel ,

    based on the details of the link the SessionHost should be the FQDN (Full Qualified Domain Name) of the SessionHost. Same for the ConnectionBrowser.

    The command should be run as an administrator of the RDS environment to modify the setting. But you could give it a try with the IP instead of the FQDN. It won't hurt but maybe it ends with an error.

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Regards
    Andreas Baumgarten

    0 comments No comments

  4. Siraj Patel 96 Reputation points
    2021-06-20T21:24:49.953+00:00

    @Andreas Baumgarten

    IP didn't work but did it via FQND. Tested but its the same :(

    Maybe its not the new connections allowed. I'm truly lost :(