Registry keys not working

GSingh101 21 Reputation points

I tried to use the ShutdownOnUserLogoff key to shutdown our Virtual PCs however even the value of '1' & '2' does not shutdown any VMs.

Has anybody else succesfully implemented this?


A set of solutions that enhance, enable, and simplify non-persistent Windows computing environments and may also be used to create more portable computing sessions when using physical devices.
463 questions
0 comments No comments
{count} votes

Accepted answer
  1. Leila Kong 3,691 Reputation points

    Hello @GSingh101 ,

    Please try to download the latest version of FSLogix 2105 (2.9.7838.44263) and check if the issue has been solved:

    Fixed an issue where the RebootOnUserLogoff and ShutdownOnuserLogoff settings were ignored.

    Please "Accept as Answer" if it helped, which might be beneficial to other community members reading this thread. Thanks for your cooperation!

    0 comments No comments

13 additional answers

Sort by: Most helpful
  1. Leila Kong 3,691 Reputation points

    Hello @GSingh101 ,

    Thanks for your query.

    1.What's your registry settings of fslogix?
    2.Is there any error message in the log: %ProgramData%\FSLogix\Logs?
    3.Did you log in as an administrator and add the ShutdownOnUserLogoff value as DWORD?

    Best regards,

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. GSingh101 21 Reputation points

    Hi Leila thanks for the response.

    1. ![109826-image.png]1 Nothing I could see in the logs referring to any of that - do you have a specific location/file log? Yes correct all was done using an Adminstrator account.


    0 comments No comments

  3. Leila Kong 3,691 Reputation points

    Hello @GSingh101 ,

    From your registry setting, it seems you didn't enable fslogix profile container. Please set the value as "1", reboot VM and check the issue again.


    0 comments No comments

  4. GSingh101 21 Reputation points


    After making the change and trying on a different Virtual PC, several reboots it still it does not work with either any user or fslogix user shutting down.

    Any thoughts?