AADSTS65001 persistent error

MDaite 21 Reputation points
2021-07-08T05:40:57.737+00:00

I configured an app with the below API permissions
![112783-image.png]1

I have granted admin consent on the Enterprise Application and have tried to grant tenant-wide admin consent as well but I still keep getting this error when I test requesting for a token via Postman.
AADSTS65001: The user or administrator has not consented to use the application with ID 'xxx--xxx-xxx-xxx' named 'xxx'. Send an interactive authorization request for this user and resource
I am Global Administrator of the tenant, and the application is still unverified as it is under testing.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,352 questions
{count} votes

Accepted answer
  1. AmanpreetSingh-MSFT 56,301 Reputation points
    2021-07-08T08:44:06.04+00:00

    Hi @MDaite · Thank you for sharing required details.

    In the token request, scopes were added as openid+profile+User.Read, which was causing the issue. The scopes must be space separated. Once we replaced + with a space between the scopes, token issued successfully without any error.

    -----------------------------------------------------------------------------------------------------------

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. MDaite 21 Reputation points
    2021-07-08T08:50:29.89+00:00

    Thank you Aman this solved my issue!

    0 comments No comments