Cannot install Outlook add-ins

JohnRInfoSystems 1 Reputation point
2021-07-14T11:31:25.853+00:00

Hi

We have started having an issue installing Outlook add-ins which were working last week.

We have an on-premise Exchange 2016 server but also have Azure AD with directory sync running.

The only change that I know of was that the Exchange server had some updates done at the weekend, dated 11/7

When we try to install add-ins via the Store link in Outlook 2016 it goes through to the install or get option and then fails with "Installation failed due to an unspecified error. Try again"

If you refresh the page we either get the same error or :

"Add-in failed to install
For this token profile, audience from inner token 'https://outlook.office365.com' should match audience of outer token 'https://outlook.office365.com/'"

I thought it might be users were logging in with a personal Microsoft account but Outlook uses their corporate account and there was a conflict.

But I've tried it on a laptop myself and ONLY logged on with the corporate account and still get the error.

This is now a major issue for us since a group of people need a specific add-in to help in their work so any suggestions very welcome.

Thanks

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,875 questions
Office Management
Office Management
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Management: The act or process of organizing, handling, directing or controlling something.
1,998 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,335 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,875 questions
{count} votes

3 answers

Sort by: Most helpful
  1. KacperRyniecSolidbrain 6 Reputation points
    2021-09-02T11:19:33.937+00:00

    Same problem. O365 environment. Any news/solutions?

    1 person found this answer helpful.
    0 comments No comments

  2. JohnRInfoSystems 1 Reputation point
    2021-07-15T08:14:18.38+00:00

    Hi

    The Exchange version wasn't updated. But some Windows updates were done at the weekend. There were actually more done last night as I was going to try rebooting the server to see if the problem would be resolved. But it is still the same.

    The Exchange version is:

    AdminDisplayVersion : Version 15.1 (Build 2242.4)
    ExchangeVersion : 0.1 (8.0.535.0)

    I don't know if the issue happened directly after the update at the weekend. I just know it was working early last week (Mon/Tues 5th/6th) and then someone reported the issue on Tuesday morning this week (13th).

    Both updates updated the Malicious Software Removal Tool

    The updates installed on the 11th were:

    Cumulative update for Windows server 2016 (KB5004948)
    Cumulative update for .NET 4.8 (KB5003542)

    Updates installed last night (14th):

    Cumulative update for .NET 4.8 (KB5004115)
    Cumulative update for Windows server 2016 (KB5004238)

    We had a problem with accessing the Store previously but I found the solution to this was adding the registry entries for TLS security. The new issue is not giving the same error messages.

    My feeling is that it is some conflict between the Azure & internal A.D. accounts but I'm just guessing. I don't know if it would show up in any logs but I don't know where to look. There's nothing in the Exchange server main event logs.

    Thanks


  3. Otmois 1 Reputation point
    2021-08-03T11:45:37.477+00:00

    I have the same problem, with an M365 enviroment

    0 comments No comments