Cannot share outlook shared calendar microsoft exchange

AmyK22 1 Reputation point

Can't open invitation to share Outlook Calendar

Getting the following message, "the sharing message is not valid, or the data has expired.please request the originator to send a new sharing invite."

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,947 questions
{count} votes

2 answers

Sort by: Most helpful
  1. JR K Yoshikawa 11 Reputation points

    Ask Calendar Owner to check Sharing and permission on OWA.

    0 comments No comments

  2. Jade Liang-MSFT 9,956 Reputation points Microsoft Employee

    Hi @AmyK22 ,

    What's the version of your Outlook desktop client(File>Office account>About Outlook), please first ensure that you are working with the latest version of Outlook client.

    I understand that you shared the calendar via "share calendar" option and send an invitation like below, is it right?

    If so, did the issue occurred on any specific users or all users in your organization?

    • In order to confirm if the issue is related to your client, it's recommeded to log into the web mail to check if you could open the calendar normally there. If you also couldn't open the calendar there, the issue may be related to the sender or your mailboxes instead of Outlook client.
    • Based on my research, the issue may occur when the sender compose the invitation with auto-complete list, in this case, it's recommended to type the recipient's address mannually in the invitation to check if the issue has any differences after that.

    Also, as I know, we could actually share the calendar to others through many ways, as an alternative, it's also recommended to share your calendar via delegate access or calendar permission and open the calendar directly for testing.

    Here are steps how to share user A's calendar to user B via calendar permission:

    • right-click user A's calendar >calendar properties>permissions>Add> choose user B>set the permission)


    • Open the share calendar in user B: click Open calendar>from address book>choose the user A


    If that's not your case or you still need further assistance, please fee free to post back.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.