Cannot install azureml-sdk without dependency conflicts

Elia 11 Reputation points
2021-09-09T10:14:05.263+00:00

I'm trying to install the latest azureml-sdk (1.34.0) inside a new conda env (with python 3.7) but the installation ends with the following error:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
knack 0.7.2 requires argcomplete, which is not installed.
knack 0.7.2 requires colorama, which is not installed.
knack 0.7.2 requires pygments, which is not installed.
azure-functions-devops-build 0.0.22 requires jinja2, which is not installed.
azure-cli-core 2.10.0 requires argcomplete~=1.8, which is not installed.
azure-cli-core 2.10.0 requires colorama~=0.4.1, which is not installed.
azure-cli 2.10.0 requires azure-mgmt-keyvault~=2.2.0, but you have azure-mgmt-keyvault 9.1.0 which is incompatible.
azure-cli 2.10.0 requires cryptography<3.0.0,>=2.3.1, but you have cryptography 3.4.8 which is incompatible.
azure-cli-core 2.10.0 requires azure-mgmt-core==1.0.0, but you have azure-mgmt-core 1.3.0 which is incompatible.
azure-cli-core 2.10.0 requires msal~=1.0.0, but you have msal 1.14.0 which is incompatible.
azure-cli-core 2.10.0 requires msal-extensions~=0.1.3, but you have msal-extensions 0.2.2 which is incompatible.

How can I solve it?

130764-image.png

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,721 questions
{count} vote

2 answers

Sort by: Most helpful
  1. Elia 11 Reputation points
    2021-09-09T14:14:06.617+00:00

    @Ramr-msft Thanks for your answer.
    I've just run the following comands:

    1. conda create -n myenv python=3.7
    2. conda activate myenv
    3. pip install azureml-sdk --no-cache-dir
    1 person found this answer helpful.
    0 comments No comments

  2. Ramr-msft 17,731 Reputation points
    2021-09-09T14:24:58.08+00:00

    @Elia Thanks for the details, We recommend that you always keep azureml-core updated to the latest version.

    Upgrade a previous version:

    pip install --upgrade azureml-core  
    

    We are able to install the latest azureml-sdk (1.34.0) successfully without the above mentioned error in conda environment. Please find the below snapshot for the same.

    130821-image.png

    1 person found this answer helpful.