Sometimes I cannot log onto my VM

John Papaioannou 21 Reputation points
2021-09-28T12:22:25.973+00:00

Sometimes I cannot log onto my VM and I get the following message,

"Remote Desktop Connection

An internal error has occurred"

Azure VMware Solution
Azure VMware Solution
An Azure service that runs native VMware workloads on Azure.
338 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. prmanhas-MSFT 17,901 Reputation points Microsoft Employee
    2021-09-28T12:44:56.84+00:00

    @John Papaioannou Thank you for your query!!!

    As mentioned in this post and answered by my fellow colleague with a similar ask can you check the below steps and see if it helped or not?

    1)Change Remote Desktop Connection Settings
    Go to the Start Menu, search for Remote Desktop Connection, and open it up.
    Click on Show Options to unveil all the settings.
    Switch to the Experience tab and then make sure ‘Reconnect if the connection is dropped’ box is checked
    Try connecting again.

    2)Changing MTU Value
    To change your MTU value, you will have to download a tool called TCP Optimizer. You can download it from https://www.speedguide.net/downloads.php.
    Once downloaded, open up TCP Optimizer as an administrator.
    At the bottom, select Custom in front of Choose settings.
    Change the MTU value to 1458.
    Click Apply Changes and then exit the program.
    Check if it fixes the issue.

    3)Changing Security of RDP in Group Policy Editor
    Go to the Start Menu, search for Local Group Policy and open up ‘Edit group policy’.
    Navigate to the following directory:
    Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Security
    On the right-hand side, locate the ‘Require use of specific security layer for remote (RDP) connections’ and double-click it to edit it.
    If it is set to ‘Not configured’, select Enabled and then in front of Security Layer, choose RDP.
    Click Apply and then hit OK.
    Restart your system so that the changes take effect.
    Try connecting again.

    4)Disabling Network Level Authentication
    Go to your Desktop, right-click on This PC and select Properties.
    Click on Remote Settings.
    Under Remote Desktop, un-tick the ‘Allow connections only from computers running Remote Desktop with Network Level Authentication’ box.
    Click Apply and then hit OK.
    See if it isolates the issue.

    Many folks on the thread have mentioned that usually 3rd step helped them out with resolving the issue so you can check same as well first.

    Hope it helps!!!

    Please "Accept as Answer" if it helped so it can help others in community looking for help on similar topics

    1 person found this answer helpful.
    0 comments No comments