Master Data Services 2019 - Derived Hierarchy issue

Stodůlka Petr 1 Reputation point
2021-11-11T16:26:02.323+00:00

Hello,
I've been facing an issue with a Master Data Services (MDS) derived hierarchies. At first the hierarchy worked fine but after some time (do not know how long) I am not able to load the MDS data via Excel with MDS 2019 Add-in. I am receiving an error "Exception from HRESULT: 0x800A03EC". If an attribute which is filtered by the derived hierarchy is excluded from the load, the data is loaded just fine.
I believe that that the issue will not be related to MDS since it's working fine via Web Application. Moreover, two of my colleagues does not have this issue.

Results from tracing:
MDS Warning and Error tracing on the server:
Time,CorrelationId,Operation,Level,Message
11/11/2021 16:42:18,00000000-0000-0000-0000-000000000000,Unknown,Start,"Service started successfully, Assembly version: 15.0.0.0, file version: 15.0.4178.1"
11/11/2021 16:42:18,00000000-0000-0000-0000-000000000000,Unknown,Error,"ApiContractVersion: 8000"

Excel Add-in MDS log:
Attached in txt file.

App versions:
Microsoft SQL Server 2019 MDS Add-in for Excel 15.0.2000.5
Microsoft® Excel® for Microsoft 365 MSO (Version 2110 Build 16.0.14527.20234) 64-bit
MDS database located on Microsoft SQL Server 2016 (SP2-CU17) (KB5001092) - 13.0.5888.11 (X64) Enterprise - Server A
MDS 2019 service - Server B

I also tried to reinstall the whole Office 365 and MDS Add-in for Excel but the issue still persists. I've also compare app versions with my colleagues and the versions are the same. I would be grateful for your opinion and potential solution.

Thank you,
Petr

148575-mdslog.txt

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
8,572 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. YufeiShao-msft 6,871 Reputation points
    2021-11-12T02:23:14.393+00:00

    Hi @Stodůlka Petr

    The error code 0x800A03EC (or -2146827284) means NAME_NOT_FOUND; in other words, you've asked for something, and Excel can't find it. In general, you are asking for something with a specific name and it doesn't exist.

    If the field value starts with an equal sign (=), it can sometimes cause an exception.

    You can first exclude the data you need to import

    https://stackoverflow.com/questions/891394/excel-error-hresult-0x800a03ec-while-trying-to-get-range-with-cells-name

    -------------

    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  2. Stodůlka Petr 1 Reputation point
    2021-11-15T16:02:40.64+00:00

    Hi @YufeiShao-msft ,

    Thank you for your answer. Well I am not able to exclude the data since they are important to users. My only solution is to turn off the derived hierarchy but it's not the solution what I want since the derived hierarchy works fine for some of my colleagues.

    Since I only use MDS Add-in for Excel and do not use any manual functions start with (=), I think that Excel is not able to find some function/object of the MDS Add-in.
    I also tried to disable the error checking for formulas: Options-->Formulas with no success. Based on the link you sent, It also could be related to a language. However, my OS and Excel use English. So this shouldn't be a problem.

    I really do not know where could be the source of this issue.

    Thank you,
    Petr